"To execute processes, please activate a license." - common solutions not working

Installer(.exe or .msi): .exe

License type(Free, Trial/License code): Free

Studio/Robot version: 19.6.0

Current behavior: After reinstallation with cleaning AppData folders it is impossible to execute process due to license problem.

Screenshot:

Hi!

I’m sorry if there is an answer for my situation but I could not find resolution myself.

Problem started when I moved Virtual Machine with UiPath from one physical server to another.
After VM start I switch license for new Device ID, and everything works pretty fine, when I start scripts from UIPath Studio. But when tried to start script from Command Prompt or from Task Manager it didn’t works.

  1. First problem was with net.pipe error, but few restarts of machine resolve it.
  2. Then script cannot be executed because Robot has no rights to directory with project. I resolve it to, by add permissions to directory once again.
  3. After that I received another problem with robot permissions itself. Following some instructions from this Forum I reinstalled whole UiPath with cleaning folders in AppData directory. I get Free License and not connect to Orchestrator.

After that I started my script from Command Prompt successful two times, and after this two tries I received error mentioned in topic: To execute processes, please activate a license.

Found answer to reinstall Studio with clean folders in AppData as a resolution, but I already did it.

Any ideas how it doesn’t works? I spend many hours till now, and I’m ran out of any ideas myself.

And one more thing. Everything including starting script from Command Prompt and from Task Manager works fine before I migrate VM to new server.

Thank you in advance for any tips.
Best regards,
GiS

Hi @GiS,
Try to clean this folder:

C:\Users\<yout username>\AppData\Local\UiPath\License

Then you could also connect Robot to orchestrator. Please also remember that Studio Community Edition requires constant internet connection. Otherwise it will fail with this error on every run.

Hi @Pablito!

Thanks for quick reply.
Unfortunately I already did it two times with fresh install. To be honest I drop all UiPath and NuGat related folder I found in AppData.
After second reinstall I started script from Studio, and it works fine, then I started it from Command Prompt, and it works with no error. Then I tried from Task Manager and error occurs. After first error it is no more possible to start script from Studio and Command Prompt.
After restart machine I started script once from Studio - works fine again, but after second try from Studio error occurred again.

I prefer not to reboot machine after any script execution:)
Any ideas?

Thanks!
GiS

ps. and I forgot to mention: I have internet connection and antivirus is turned off for now.

No internet is probably the case here.

Internet connection is not a problem in this case. I have it.
I checked it by ping DNS during script execution and with connection everything is fine.

Ok so if internet connection everything is fine, you could connect robot to orchestrator and activate the licence through orchestrator. This solves many issues like this.

Thanks!

Activate license throuhh Orchestrator resolve the problem. I had another issue with privilages but I resolved it using this: https://www.thewindowsclub.com/required-privilege-not-held-client.

For now everything works pretty fine.
Thank you for your help.
BR,
GiS

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.