Timestamp in ElasticSearch and Kibana is displaying same Hours, minutes and seconds for different logs

Hello.

We have an issue within our organization, with the timestamp in Kibana.
Our Orchestrator is connected to ElasticSearch and the whole view of our Robot’s run we have in Kibana.

The problem is that log messages from our Robot’s are not displaying in a correct order, as you can see on the attached screen 5 logs were performed in the same time, which of course it’s not a true. Sometimes it’s very annoying because firstly it’s saying ‘Complete get transaction data’ and after that ‘Started get transaction data’ - it should be the other way around

Do you guys have any advices, ideas what settings should we change?

Maybe it’s just a way of breaking seconds into smaller from this format HH:mm:ss.SSS ?

I’ve already talked with the guys from elasticSearch they said that issue is not on their site, it’s something related to UiPath

image