Timeout reached when the remote desktop is not connected

I’ve community edition unattended robot. My process opens a chrome browser and type in ‘user’ and ‘password’ with the parameter values and click the ‘login’ button. It runs fine from orchestrator if I connected to the remote machine(which the robot runs ) by remote desktop.
However, if I disconnected the remote machine where the robot runs, it always failed with this error.

==========================================================================
Timeout reached.

RemoteException wrapping UiPath.Core.ElementOperationException: Timeout reached. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()…

And the log on the machine shows error.

Error {“message”:“Type Into ‘INPUT user_name’: Timeout reached.”,“level”:“Error”,“logType”:"Default …

I set the Robot as ‘LoginToConsole’ as false. But still no luck.

Is there a way to run the process regardless remote desktop running?

Thanks.

Any comments are welcome… Please help me on this issue. Thanks.

Hi @smyung
My suggestion is to add Log Message activities for every major milestone in your automation. So rather than checking how your Robot is doing via Remote Desktop, you can check how the Robot is doing via the Job Logs.

After some investigation, found out that the robot behaves differently per version.

With Robot version 2019.10.2, it works without remote desktop running if I disable ‘LoginToConsole’ . I restarted the robot at target after this setting. As soon as the process started, the remote desktop connection is closed and the process is done successfully.

However, with Robot version 2020.6.0, it always requires to have remote desktop opened. Without the remote desktop running, the ‘timeout reached’ error happened as I mentioned above. I modified ‘LoginToConsole’ like I did for Robot version 2019.10.2, but it still required to have remote desktop opened.

But I don’t think remote desktop is required for the robot. Is there a way to make the robot working without remote desktop running?

Thanks.

2 Likes

solution for this @ovi ?

I am having the same issue. @smyung , did you find a solution to this? Or can anyone else have any ideas?

Hi @smyung , Could you resolve this issue? Thank you for your quick response.

Don’t disconnect. Log out. Then run the job.

I am facing same issue. any solution for this?

Orchestrator version: 2021.4.0
Studio version: 2021.4.4

Having same issue.

Studio version: 2021.4.4

I’ve also had this issue.
Try to use “Simulate click/type” for every activity and let me know how it goes.

Same issue

Orchestrator: 2021.4.0
Studio: 2021.4.4

Tried to remove ‘Lock screen’ using registry settings, Executing Tasks in a Minimized RDP Window changing rdp settings, updating activity versions in the project, About UiPath Remote Runtime.

Tried “Simulate click/type” and it partialy worked, but considering that some actions are made using old actions, rewriting whole process might not be an option in the future.

Hi @gendalfas,

Please try the robot settings I posted in this thread. Your robot will work as intended the Log to console setting is the one which will allow your robot to login properly and you do not need to limit your robot to background activities like simulate events.

Does not work. I tried changing a lot of settings and registry values… Timeout Reached 오류 해결 경험 공유

Problem is that chaning processes after each UiPath update does not make the tool robust to make automations in the long run if then we will have to spend months updating solutions instead of creating value.

Hello. I´m having the same issue with community version 2021.4.4. ¿Has a solution been found?

Note: I’ve tried every propousal except the robot settings because I´m unable to access them. If anyone can help with this, thanks in advance.

It’s an unattended robot, update the password of that robot from the orchestrator and it’ll be sorted