Timeout Error of Unattended Robot in Activity "Type Into" Windows Command Line

Hi Friends,

I am having following error message when I tried to execute a command in windows command line using activity of “type into”.

Timeout reached.

RemoteException wrapping UiPath.Core.ElementOperationException: Timeout reached. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Besides “type into”, there are other activities (e.g. open browser, click etc) which are found working well).

It seems that the problem only occurs when the PC is locked.

If I were to select “True” for “Simulated Type”, the text would somehow appear as the title of the command line window, instead of being a command.

Thank you and look forward to your advices.

Cheers.

can you create a .bat file with the command inside, then use “Start process” activity to run the .bat file instead. This should work even if the PC is locked

Hi @jack.chan,

Sounds good. Let me have a try.
Thank you.

Hi Jack,

Here is another question if I am to use batch file: how would I key in my response to the system in command line? My response may be varying, e.g. the current date.

There is argument for “start process” which I find it is parameter but not “response”.

hi, do you mean you have to type in another command after the program prompts you for a response?

Hi @jack.chan,

I need to respond to the system by key in some data, which I have to use “type into” activity.

It is wieard that the problem only happens to command line window when the screen is locked. For web activities (like click and type into) the problem can be solved by choosing “true” for “simulated type”. However, when this is selected, the text would be typed to the title bar of the window instead.

refer my experience

Timeout Reached 오류 해결 경험 공유 - Ask in Your Language / Korea RPA 개발자를 위한 공간 - UiPath Community Forum