Time out Error

I have click activity inside a workflow which gives me timeout reached error if I do not use the workflow for more than 1 hour.
What I tried:
1.Changed selector
2.Deleted activity and choose it again
3.Tried with UI Explorer and Attach to live event.
4.Re-installed studio and packages.

After every 1 hour, I have to repeat the 4th steps. This is irritating.
Someone, please help me to sort it out


This error is likely to come because, after some time, your RDP session is becoming “UI-less”
You may want to try what @badita is mentioning on this link.

If I remember correctly, those changes need to be made from the client opening the RDP session (the computer opening the RDP window)

@claytonM is also giving potential workaround using Launch workflow interactive.


1 Like

Yeah, you would need to provide more details as to when or why it is getting a timeout error. Like for example, if you are minimizing or closing the RDP window then that will be the issue which @Florent_Salendres mentions a potential solution for above.

Another culprit I have seen is in Windows Server where the Start Screen is the first screen that comes up when you login, where the UI can not see the desktop. There was a registry fix to disable the Start Screen on logon for Windows Server 2012 but in Windows Server 2012 R2 I believe it was suppressed by default.

There are some other settings in Windows Server that can cause issues as well, like the Desktop Experience needs to be enabled if I remember right.

If it times out while you are watching it, then in that case, it’s most likely a selector or timing issue.

Launch Workflow Interactive was a method to solve for interactions that are impacted by resolution or color depth, and could also be a way to simulate unattended by turning on the console use. However, Orchestrator v18 supposedly addresses this with the option to set resolution settings for each robot. If the workflow is being run as attended then it really doesn’t matter because it will use the settings that you are logged in RDP with.


1 Like

I Have installed Studio on windows server 2008 R2. The window where it has to be clicked is open in the background. So after running the workflow, my desired window will be open on the screen. I am not minimizing or closing the RDP window.

Yes, it is RDP. The link provided link is not working. I do not understand by “Launch workflow interactively”.

I have installed beta version but still getting the same error.