Throw Activity freezes the process

Hi All,

I have a scenario where I’m using UiPath Studio 2019.3.0 and the bot works perfectly fine. But when I run the same robot in UiPath Studio 2019.12.0-beta.61 the robot freezes when it reaches Throw activity. It doesn’t process the throw steps. Please advise.


Welcome to UiPath Community!

Are you getting any error there?

you can try by deleting that activity and replace with a new one from 2019.12 version.

I did try replacing the activity with the new “throw” activity. Its still the same. There is no error. It just freezes.


The workflow has any try catch block, try with a try catch block, Start the workflow with Debug mode, so in the output window you can see which is faulted activity by searching for faulted in the output window.

I figured it out !! In UiPath [Studio]2019.12.0-beta.61 the “Play” button by default executes the Bot in Debug mode which is not the case with UiPath [Studio] 2019.3.0, that’s the reason it was pausing Throw activity !!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.