The Uipath bot could not interact with the java application

Hi All

I built the Uipath bot interacting with the Java application in the Uipath 2019.10.4 studio version. The bot faced the issue interacting with the Java application if the VM disconnected/ closed. If the VM is open (login to the VM), the Uipath bot interacts with each element in the Java application.

FYI. I did not receive any error when installing the Java extension in the robot machine.

Last year, the Uipath Technical team advised me to enable the login to console option in the robot settings in the Orchestrator to False. I followed the steps and the Uipath bot interacted with the Java application even though the VM disconnected.

This issue starts again after I install the Uipath studio version to 2020.10.10 and the Orchestrator version to 2020.10.1 from 2019. Until I open the VM, the bot is not interacting with the Java application.
I have also enabled the login to console in the robot settings in the Orchestrator 2020 version to False, but the issue still exists.

Did any of you come across this issue and resolve it? Please share your comments.


Hi @G3Devi ,

Welcome to the community!

I think @loginerror can help you here.


Hi @G3Devi

Have you tried reinstalling the Java extension?

Otherwise, I would advise you to once again reach out to our technical support team for advise:

Hi @loginerror

Reinstalling the Java application did not help. Today, I spoke to the Uipath Technical team. She tried many ways by installing the Uipath service file (2020.10.10) and adding the resolution width, height, depth, but the Uipath Robot interacts only if the VM is open.

She will check with her team and will come back.


Hi All

We resolved the issue by adding the environment variable of the UIPATH_SESSION_TIMEOUT with the value of 60.

  1. Open the RUN command.
  2. Enter the SystemPropertiesAdvanced on the RUN command.
  3. Click on the Environment variables button under the Advanced tab
  4. Add/ update the ‘UIPATH_SESSION_TIMEOUT’ with the value of 60.

Thanks to the Uipath Technical Team for resolving this issue.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.