The type 'ILocalResource' is defined in an assembly that is not referenced


I am trying to compile and publish a library that has been working for several years, but all of a sudden fails with the following error:

The type ‘ILocalResource’ is defined in an assembly that is not referenced. You must add a reference to assembly ‘UiPath.Platform, Version=, Culture=neutral, PublicKeyToken=null’

I have tried installing the package “UiPath.Platform”, but it is automatically uninstalled during compiling/publishing and then followed by the excact same error.

we would assume that some packages were updated before the publishing, right?
In general we would recommend to downgrade the UiPath.System.Activities to a Level that is not defining a dependency to UiPath.Platform

Let us know the following:

  • Studio Version
  • defined Dependencies
  • programming language
  • selected target framework (legacy, windows)

I am not upgrading any packages - simply changing some text in a log message.

The previous package was published and submitted to Bitbucket in Studio 22.4 and I am now trying in 22.10.

thanks fo r the first feedback. Still let us know also the other open questions:


  • UiPath Studio 22.10.4
  • Library VB, Windows-Legacy
  • Dependencies as shown below
  • My colleague is having the same error when trying
    I can try to downgrade UiPath.System.Activities to a lower version and check again.

And here are logs if you need them. (27.4 KB)

also downgrade in the samel level (22.4, 21.X…) the Package UiPath.UiAutomation.Activities

The current published version already contains the newest packages, so it seems to relate to the version of Studio that I am running, since it is the only thing that has changed between publishing.

I am hindered in rolling back UiPath.System.Activities and UiAutomation.Activities as many of the other dependencies are relying on the newest version :face_with_diagonal_mouth:

we were talking about downgrading (going to lower versions)



it was not defining the latest versions (as for years back 22.10X was not existing) when it was working the last time back

However you can detect a few resolving block be expanding the subdependencies and and checking the ligth blue references (light blue - indicating that the package was resolved alternately)


I know that you are asking me to downgrade, but it strikes me as strange that the current version of this library already have all the newest packages installed, and is working fine.
But when changing a simple log message and publishing a new version (without changing any packages/dependencies) then all of a sudden it fails and complains over missing references.

I am not able to downgrade the 2 packages in this library, as other dependencies are relying on the newest versions of System.Activities and UiAutomation.Activities, and this library (which is failing to publish) is relying on changes in those other dependencies.

ok, thank you for the feedback

Anyone else experiencing this issue?

Compiling fails with missing references to an already installed dependency.

I have now downgraded one of my developer-machines to UiPath Studio 22.4.1.
Compiling completes on this version, so it must be related to newest version of UiPath Studio.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.