The trigger works but the process does not run

Good morning friends, please I need your help please:

When I am on the server (windows server 2012 r2) connected via remote desktop, everything works fine, but when I exit the remote desktop and then enter to check if the trigger was executed, only one activity of the whole process appears, that first activity was open a url, then log in … but only the user entered the password, but I can’t click on the “log in” button

I get the following error in the log:


"Info: Timeout reached.

RemoteException wrapping UiPath.Core.ElementOperationException: Timeout reached. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager) "


Hi @gusherrrera ,

Could you check what type of license you are using for Bot. if you running process from orchestrator in that case you have to use un attended bot license.

if you are using un attended bot license but still you are receiving this time out in that case go to task manger services restart UiPath robot service and restart your VM if possible and try.

if still not working try to use simulate options like simulate click instead of normal click and try.

Could you please follow above and let us know. thanks.

I am using unattended bot with community license, while I am connected to the server via remote desktop, the unattended bot runs the entire flow correctly at the scheduled time.

But when I’m not on remote desktop the unattended bot runs at the right time, opens the url but can’t enter the user.

I tell you that I had a very rare bug using the remote desktop windows server 2012r2. When someone connects to the server through a pc with a resolution configured for 4k screens, the bot does not work, apparently the positions of the objects on the web vary in the bot not locating them correctly.

When I connect to the server with a pc that has a 1080p resolution, that is, HD, the bot works correctly, the whole flow ends.

So, I am suspecting that the problem comes from a screen resolution issue that the server has by default.

I checked the logs in more detail and there is a part that says “Type Into ‘INPUT’: Timeout reached.”

you can configure the unattended robot to always operate on the resolution that it works on. Timeout reached is because the element is not found as the resolution is changed.

Below thread might helps:

1 Like

Thank you very much Rahul Sharma, with your information I solved the problem

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.