The specified combination of selector, filter and scope is not supported

The top of the workflow and the location of the error can be seen above. I am working on Practice 2 of the Selectors in Studio lesson (which involves entering data into the RPA Challenge), and when I tried to use the Indicate Anchor feature as the activity instructed, my selectors were all wrong. I asked about this elsewhere on the forums, and I was advised to use Anchor Base instead, so I tried that. However, Anchor Base is now giving me an entirely new error, and I have no idea how to proceed. How do I respond to this error?

Hello @Jack_Moran

Anchor base is used to tag a field to a related element for easy mapping.

Here if you have used the anchor , in the find element you need to provide the label and in the type into you need to provide the field to enter the data…

So plz validate the selector. Also try to check with the recording also.

1 Like

I just checked the validation button, and sure enough it is red. Here’s what I’ve got for the selector shown above:

This is the selector for the Company Name input field. In spite of the fact that the find element provides the label, this validation error still happens. Does this mean I did something wrong while anchoring this to the label?

Yes, you can inspect on that field and if there are any changing attributes, those values you can remove from selector and validate.

1 Like

Unfortunately, whatever changes I try produce the same error. I tried removing nav up, the id, and even tried using the UI Tree to make sure aaname was involved in the exact right way… no dice. What do I do now? It seems that no matter what I do, this anchoring solution that should be perfectly acceptable breaks down.

Hey @Jack_Moran

The selector configuration is not proper which is causing this error.

  1. Find Company Name activity should hold the selector only for the label Company Name

  2. Type into will just hold a generic input element selector

Hope this helps


1 Like

Good evening Nithin,

I implemented your suggestion of using a selector that ONLY involves the generic input selector, as follows:

<webctrl tag='INPUT' />

With this selector, the program can now start without generating a syntax error. However, with the anchor unchanged the program simply types the Company Name into whatever field is on the top left, regardless of the label. I tried making the anchor more specific by adding some things in the UIExplorer, but that simply caused it to input the information on the top right instead. What should I do now?

Okay @Jack_Moran

Actually the Anchor should be updated as well.

Could you please show the currently used selector for Anchor ?

1 Like

<html app='chrome.exe' title='Rpa Challenge' /> <webctrl aaname='Company Name' tag='LABEL' />

1 Like

Ok looks perfect.

So you have three anchor base for three fields.

1 Like

I thought it looked perfect too! How bizarre… in any case, this was the sort of anchor I was going to implement for the remaining fields as well. However, since this anchor base pairing is not working, I have yet to re-do the rest. Also, I plan to implement an anchor base for every field on the site, not just three fields.

1 Like

Sorry not getting you.

The Anchor base should be obviously set for each field separately.

And the anchor always have corresponding label selector where as the type into is same for all - a generic input selector

1 Like

Oh yeah, I understood what you meant. Its just that as you saw above, even though your method should work, it just didn’t for some reason. Regardless, thank you for your help! You’ve gotten me one step closer to a solution. I’m going to talk to my managers about this issue, and if they are able to figure it out then I will go ahead and post the answer here.

1 Like

Sure @Jack_Moran Happy to help further if required!

1 Like

With some help from my awesome coworker Athena, I managed to figure it out! As it turns out, the issue at the heart of all this was actually the use of Open Browser. The Practice’s step-by-step solution instructs you to use Open Browser, and because the difference between this and Attach Browser is negligible, I thought nothing of it. But when I switched to Attach Browser as Athena suggested, the correct fields were finally selected.

To those of you looking at this in the future, the rest of the solution is to use a generic selector for your input fields as suggested by @Nithinkrishna, and to ensure that you can validate each piece of the Anchor Base as suggested by @Rahul_Unnikrishnan. Above all else, do not use Anchor Base within Open Browser!!

1 Like

Cool @Jack_Moran :+1::white_check_mark:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.