The project has Workflow Analyzer errors and cannot be published

Get this error when trying to publish project to orchestrator:

“The project has Workflow Analyzer errors and cannot be published. Check global publishing settings allowed by your team.”

“Could not load file C:\ProjectFolder\Main.xaml. Reason: The invocation of the constructor on type ‘UiPath.Core.Activities.GoogleCloudOCR’ that matches the specified binding constraints threw an exception.”

Process works fine when launched from studio. In Studio settings “Enforce Analyzer before publish” is disabled.

If i enable from settings “Enforce Analyzer before Run”, i get same error when trying to run project in Studio.

You have something wrong in your code. You should fix it instead of trying to bypass analyzer and publish a project that has errors. The activity that’s got the problem should be highlighted with a red or yellow icon.

I am getting the same error, any solutions? Not sure exactly what is the issue with the GoogleOCR activity that is causing it.

HI @mikko1,

  • Ensure that you have the latest version of the UiPath.GoogleCloudOCR.Activities package installed in your project.
  • Check if there are any missing or conflicting dependencies in your project. You can use the Dependency Manager in UiPath Studio to manage your project dependencies.
  • Remove the Google Cloud OCR activity from your project and try adding it again. This may help in resolving any configuration issues with the activity.

I have all packages latest version. But can’t find UiPath.GoogleCloudOCR.Activities at all with Dependency Manager. Not in Project Dependencies and not in All packages.

I have several projects what use same Google OCR and they all can published. In fact, this project what causes problem, is copied from one excisting project and modified.

Hi @mikko1
Before publishing the process you need to click on workflow analyzer and check what is the exact issue.

About workflow analyzer…please read this one

Workflow Analyzer points error to “UiPath.Core.Activities.GoogleCloudOCR” package.

But it’s not listed on project dependencies and i can’t also find it from Package Manager, not in Project Dependencies and not from All packages.

But this project runs fine in dev machine and i have before been able to publish it to Orchestrator. This change in behavior has probably come after UiPath Studio has updated?

Did you used some libraries created on your own? Maybe some of the libraries was built with this package?

Didn’t use own created libraries.

Are these libraries somewhere in harddrive as files? Have used UiPath 5 years but never studied UiPath “under the hood”

Is this a new project? Did you copy/import any files from other projects where this activity package was used?

Could you make screenshot what dependencies you are using in your project?

No, this is not new project. It’s been in use about 6 months. 6 months ago it was published to Orchestrator, and now when trying to publish it comes Workflow Analyzer Errors.

When project was made, OCR activities where copy/pasted from another project. Project where they were copied, is possible to publish to Orchestrator.


@mikko1 *Did you solve this? I get the same exact error after upgrading UiPath Studio to the latest version.

There is a package called UiPath.Core.Activities.GoogleOCR inside of UiPath.UIAutomation.Activities which is the Tesseract OCR

also here explains more: GoogleOCR The invocation of the constructor on type - #4 by Midwayuser

A little bit offtopic: I would not recommend using preview packages, because they can be removed from UiPath feed. It also can contains some bugs.

Preview version are published to be tested with community edition and to share with some new features available in next releases.

UiPath.UIAutomation.Activities is not preview but i get what you are saying