The project has the same name as a referenced package ("UIPATH"). This scenario is not supported and will lead to dependency resolve issues

I’m getting this error when I try to open Notepad.xaml which is one of the examples for level 1, lesson 3 Recording.

Does anyone know how to fix it because I can’t run the example due to a different error which is caused by this error.

This is the error when I later try to run the Notepad.xaml: next post

Source:  Type into 'editable text'

Message: One or more erros occurred.

Exception Type:  System.AggregateException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.AggregateException: One or more errors occurred. ----> System.IO.FileNotFoundException: Could not load file or assembly 'UiPath.Interop, Version=0.0.3.0, Culture=neutral, PublicKeyToken=461894da7f0ba157' or one of its dependencies. The system cannot find the file specified.
   at UiPath.Core.UiElement..ctor(SelectorStrategy strategy)
   at UiPath.Core.Activities.Services.DriverService.CreateElement()
   at UiPath.Core.Activities.Target.<>c__DisplayClass35_0.<GetBaseElement>b__0()
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()
   --- End of inner ExceptionDetail stack trace ---
   at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
   at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)
   at UiPath.Core.Activities.Target.GetBaseElement(ActivityContext context, CancellationToken token)
   at UiPath.Core.Activities.Target.GetFindMethod(TargetFindCriteria criteria, CancellationToken ct, Int32 defaultTimeout)
   at UiPath.Core.Activities.Target.GetElementAsync(TargetFindCriteria criteria, CancellationToken ct, Nullable`1 delayBefore)
   at UiPath.Core.Activities.TargetAsyncActivity.GetElementAsync(AsyncCodeActivityContext context, CancellationToken ct, Nullable`1 delayBefore)
   at UiPath.Core.Activities.BaseTypeInto.ExecuteAsync(AsyncCodeActivityContext context, CancellationToken cancellationToken)
   at UiPath.Core.Activities.TaskAsyncCodeActivity.ExecuteAsyncWithResult(AsyncCodeActivityContext context, CancellationToken cancellationToken)
   at UiPath.Core.Activities.TaskAsyncCodeActivity`1.BeginExecute(AsyncCodeActivityContext context, AsyncCallback callback, Object state)
   at System.Activities.AsyncCodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
   at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
   at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

This is for example given for the Recordere called Notepad.xaml which looks like:
image

Edit: I think this is the key line:

System.IO.FileNotFoundException: Could not load file or assembly 'UiPath.Interop, Version=0.0.3.0, Culture=neutral, PublicKeyToken=461894da7f0ba157' or one of its dependencies. The system cannot find the file specified.

The recorder function is not working as I am getting this error when I click Start App for level 1 lesson 4 practice 1:

image

Hi @nyck33

Could you try this solution?


It’s a long shot, but worth trying.

I it wont, you can try creating a new project and recreating the example. That should work for sure.

It might also be that deleting the project.json file and relaunching the project will work.

@loginerror I have tried changing it to Main.xaml and main.xaml but I’ll try deleting the json.

In the meantime, I found a discrepancy in Write Range : https://superuser.com/questions/1436255/uipath-studio-write-range-does-not-have-a-file-path-parameter-in-ce

This comes from two different Write Range activities - one for Excel Application Scope and the other for workbook activity pack, see the difference here:
image

The workbook one will be the one with the path. The other one takes the path from the Excel Application Scope activity.

1 Like

@nyck33 Were you ever able to find a solution to this? I am struggling with this same error.

Hi @GTowerz

Please make sure that:

  • your project is not called UiPath
  • the xaml file you try to run is not in the UiPath folder

This will result in the errors :slight_smile:

Hey @loginerror , thanks for the help!

I ended up realizing that I kept getting the error because I was using an old project on an updated version of UiPath, and a lot of the dependencies didn’t seem to be compatible for some reason.

I fixed this issue by copying and pasting my old sequences into a brand new project. Hopefully this quickly helps anybody in the future :slight_smile:

1 Like