The process cannot access the file


Having an issue where the Get PDF Page Count will not run “because it is being used by another process”. I get what this means normally but the pdf was created during the project and it is not open when I attempt the run the page counter.

One thing to note is that I am using a variable to call the file since I am using it for a weekly report and have it update the location based on the date. Also when I use the retry step (without touching anything) it usually works… -_-


Hi @heblightning - See if AcroRd32.exe is running in the background…

Or you can try kill process to close the AcroRd32.exe…then the try to attemp the Get PDF Page Count…


@heblightning - any luck?

I’m not sure how to enter the information into the Kill Process activity. :grimacing: Do I put “AcroRd32.exe” in the Process?

Hi @heblightning – As shown below…This for the reader…

if you have are using different application, you can go to task manager and under the details, it will show the exe name. Take jus the name without exe and provide under the Process Name…


1 Like

Unfortunately, it still threw the error. I’ve also tried closing the program I used to generate the pdf and I’ve tried using a delay. It seems to require either me starting the process at this step or me hitting retry step.