The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine

I was trying to use Excel as a database in UiPath. And while creating the connection string got the following error. I installed AccessDatabaseEngine_X64.exe and Excel 2016 on my machine. But still getting the same error.


Source: Connect

Message: The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine.

Exception Type: System.InvalidOperationException

RemoteException wrapping System.InvalidOperationException: The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine.

Server stack trace:
at System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper& datasrcWrapper)
at System.Data.OleDb.OleDbConnectionInternal…ctor(OleDbConnectionString constr, OleDbConnection connection)
at System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
at System.Data.ProviderBase.DbConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection, DbConnectionOptions userOptions)
at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup, DbConnectionOptions userOptions)
at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection) at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource1 retry, DbConnectionOptions userOptions)
at System.Data.ProviderBase.DbConnectionClosed.TryOpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
at System.Data.ProviderBase.DbConnectionInternal.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
at System.Data.OleDb.OleDbConnection.Open()
at UiPath.Database.DatabaseConnection.OpenConnection()
at UiPath.Database.DatabaseConnection.Initialize(String connectionString, String providerName)
at UiPath.Database.DBConnectionFactory.Create(String connectionString, String providerName)
at UiPath.Database.Activities.DatabaseConnect.<>c__DisplayClass15_0.b__0()
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object args, Object server, Object& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase)
at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData)
at System.Func`1.EndInvoke(IAsyncResult result)
at UiPath.Database.Activities.DatabaseConnect.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

@shahanajc need to install access database engine too.

Thanks for the reply. I have already installed but still I could not solve this.


Try to import ‘System.Data.OleDb’ in your workflow.
Type it (like above) and hit Enter (don’t just assume you have it - you need to trigger it).


Let me know if it worked…

I am also getting the same error, but installing AccessDatabaseEngine-64Bit not resolved it.
still facing issue, anybody resolved it?

You cant use x64, but x86 as uipath studio is 32 bits.


Thank you for the reply, I am not able to install the 32 bit AccessDatabaseEngine since I have office 2016 software with 64 bit. Got error during the installation for 32-bit AccessDatabaseEngine.

Link which I have tied to install for the 32 bit AccessDatabaseEngine

You would need to remove everything 64 bits from Office before that… Even MS do not advise people to install 64 bits for Office components as it will cause more trouble than good things…

1 Like


After installing the Microsoft Access Database Engine 2010 Redistributable version from the below link, the AccessDatabaseEngine service looks working. During Production move will it cause any issues?

I would be careful, but assuming you do development in a similar machine as the server of production, then installing the same wont cause issues, but if you can, in production, dont install office 64 bits.

1 Like


Thank you for the information. It is an existing machine and I am going to install the package once the develop completed.

It is similar server as the development environment. So I hope no error will occur.

after installing this also, I am getting same error. Any other solutions please?