The machine name is already taken (#1200)

I am using UIPATH studio community license and I am new to it,in the uipath orchestrator at first I created machine then created one standard robot and at that time machine name was coming to the drop down machine but due to some issue I deleted that robot and after that again trying to create another Standard robot there is no machine name is coming in the drop down also if forcely put the machine name there then thie error is coming. Please give some solution.
In the new version of uipath there is no development type. what should be the type when creating the standard robot.

What was known as the Development Robot is now referred to as Studio Robot.

If you go into Management > Machines, and ensure it is not filtered i.e. Search is empty and Type is All, is your intended Machine name listed? If it is empty, can you try creating the machine here?

If the machine does not exist and you are first creating the Robot, it should offer to create the machine with a “+ Provision Machine x”

image

If you are not getting the filtered list of an existing machine or offered to provision a new machine, by chance is your browser throwing any errors if you were to inspect it? image

In the Management>machine there is already machine exist.
still I am not getting machine name when creating the robot.

As you have mentioned there are some error in my browser. I am giving the details of error below

Error while trying to use the following icon from the Manifest: https://platform.uipath.com/dist/assets/icons/icon-144x144.png (Download error or resource isn't a valid image)
breadcrumbs.js:64 
Deprecation warning: value provided is not in a recognized RFC2822 or ISO format. moment construction falls back to js Date(), which is not reliable across all browsers and versions. Non RFC2822/ISO date formats are discouraged and will be removed in an upcoming major release. Please refer to http://momentjs.com/guides/#/warnings/js-date/ for more info.
Arguments: 
[0] _isAMomentObject: true, _isUTC: false, _useUTC: false, _l: undefined, _i: Thu Apr 02 2020 10:30:00 GMT+0530 (India Standard Time), _f: undefined, _strict: undefined, _locale: [object Object]
Error

Without additional images of it I would guess that

  • The machine that exist is of type Template and not Standard
  • The user you are creating the Robot with does not have the correct permission / roles to view and/or create Machines.

Please double check both of these.

If I remove the permission to Create Machines and View Machines or remove the permission to create machines, but have the View permissions and no Standard Machines define, I see the display that you are showing.

image

If you have Create Machine permission, you will see the "+ Provision Machine " as shown in my previous screenshot, and if existing Standard machines exists and you have the View permission you will see them listed.

Even I am facing this issue when I am following the cloud documentation:

I am able to create machine using the above link via Postman API Call. Kindly help on below error while creating robot:
{

"message": "The machine name DESKTOP-XYZ is already taken",

"errorCode": 1200,

"resourceIds": null

}

Ok I got the workaround. So instead of passing “Machine Name” I had to pass “MachineId” in my POST request. I got this “MachineId” by running another REST call to fetch all my machines which gives all MachineId in response.

Had you solved the problem?

I was getting the same error and I discover that the machine I created was of type “Template” and that was why it was not showing on the list when creating robots.

So I deleted that machine and created another one with the same name but with type “Standard” and this solved the problem immediately :+1:

Git it a try.

Regards.