The hover or click option doesn't work for my submenus

Use Case- Trying to have the BOT click on the camera and capture images and then save them. Before the click of the ‘Capture’ button, I have to click on 1 main menu (which works) and the sub menu option doesn’t do anything. Tried so many combinations and variations but nothing. Can someone please guide? Also there is an error thrown. I’m attaching 2 screenshots. OCR_Error_Menu Menu_Capture.xlsx (33.0 KB)

1 Like

Buddy @SG5

No worries
when you are clicking the main menu with a click activity, it selects that element flawlessly…great
now once after selecting the element main menu for click activity use another click activity buddy…and now you will not be in a position to select the capture option while trying to make a selection for the selector of click element, so press F2 , the selection process will be paused for 3 seconds( you can see the time running at the right bottom of the screen )…meanwhile in that gap click the main menu alone and thus drop down will come, and your 3 seconds will now be over and you will asked to make a selection again for the element in click activity…
NOW SELECT THAT CAPTURE OPTION buddy, and the element for capture will get selected in the click activity

or if you are not able to select CAPTURE as a element, you can use click image activity and select that CAPTURE option in the main menu as a image and it will click once the main menu drop down falls…try this only when you are not able to do with normal click option @SG5

Thats all buddy two click activity is enough
Kindly try this and let know buddy
Cheers @SG5

did that work buddy @SG5

Hi Palaniyappan,

Thanks so much for a detailed response. Yes I have tried all of these steps even before posting my question. (Click Image, F2, Hotkey, everything) Tries so may combinations. But it looks like it doesn’t recognize the capture at all. It doesn’t do anything at all or move forward. Not sure why such an easy thing is not working !

Hello @SG5 ,

  1. Use click activity and click on the drop-down menu which you want to click
  2. Grab second click activity and click indicate on screen.
  3. now press F2 in the time gap click on the drop down menu and when the drop down menu appears click and hold on the any sub element from the drop-down until the time of 3 seconds runs out(left click).
  4. now u click on the element which you see the drop-down not vanishing and now you can select which you wanted to select.
  5. Once i was stuck on same issue this helped me hope it does to you.

let me know if that helped.

Ashley Nihal Dcunha

Thank you so much Ashley. Yes Palaniyappan had suggested that and in fact I had tried that myself before posting it to the forum but it was more of the 3rd party application which was giving trouble than the UIPath feature. Thanks so much for your help !

1 Like