"The Connection Failed At Negotiating Security Settings" While Triggering Unattended Automation

How to fix error "Could not start executor. RDP connection failed: Message: The connection failed at negotiating security settings." thrown when triggering an unattended execution from Orchestrator?

Root Cause: This error is known to arise due to remote connections to the particular Robot machines being blocked from a system level.

Resolution: Note that even though the user is added to the Remote desktop users group and assigned the required group policies as per the Robot installation pre-requisites, their remote connection to a particular machine can be blocked from a system properties level.

This issue can also occur if the RDP listener is listening on a port other than 3389 for versions lower than 23.4

To fix this, the setting has to be explicitly disabled and can be accessed from the following location: Control Panel -> System and Security -> System -> Advanced System settings -> Remote Tab.


  • Disable the option by selecting "Allow remote connections to this computer" to fix the remote connection error and allow the Robot service to create sessions on the particular Windows machine.

Hi @system ,

We have above mentioned setting enabled as you can see in below images.

image

Still, we are facing the below issue on all of our bots and none of the jobs get started until we keep the session active using “Remote Desktop Manager” software.

we tried the below command since it was one of the resolutions mentioned from UiPath. But after running the script still we have the same issue.

“netsh winhttp reset proxy”

Is there any other way to check why the on-premise orchestrator (2021.10.2) is unable to create an RDP session with “Login to Console = No.” ? Is possible you can share any documentation to debug the issue.