Text file is not creating when run process from orchestrator

Hi Guys,

Robot is not creatingfile log.txt file when i execute the process from orchestrator. When i run the process from studio text file is creating.

Do you know why the file is not creating?

1 Like

It looks like you’re only using a relative filename. This means it is creating that file in the project folder. If it’s being run from Orchestrator on another machine/robot, then it is creating the file on that other machine. Provide the full file path (e.g. C:\temp\Yourfile.txt instead of only Yourfile.txt) if you want it to be used by multiple different machines.

Also, if the file you name is already created, it isn’t going to create another new file because the file already exists

Thanks for giving me fruit full information. I tired the full path but no luck. I am testing this on my local machine. i am facing same kind of problem in actual development environment.

Append Line will create the file if it doesn’t exist so you don’t actually need to create the file with a separate activity in this case. Try just using an Append Line with the full file path.

i have tried append line to… this will also only create file when i run process from studio.

  1. What is the path you are providing?
  2. Are you running on the same machine when you run through Orchestrator or is it a different robot?

Process run successfully without giving any error if i run from orchestrator but file is not generating or creating in the project folder.

yes i am running on the same machine. this is my full path. “C:\Users\Nividous\Documents\UiPath\create_text_file_from_orchestror\log\log.txt”

Even in actual development i have a same robot configure for UAT environment and use for same machine.

So if you delete the file C:\Users\Nividous\Documents\UiPath\create_text_file_from_orchestror\log\log.txt and then run the process from Orchestrator it fails to recreate that document but otherwise the whole process works exactly as intended?

yes sir.

What account does Orchestrator use to log in to the machine? It’s possible the robot doesn’t have permission to write to the directory, but I would think that would throw an error. Can you confirm that ContinueOnError is not set to True for Append Line.

Hi @Omer_Farooq ,

I believe the path that you have mentioned here for create file or Append Line activity is a relative path which will basically create the file in current folder from where the project is running.So, when you run the process from studio you get the file created.

When you publish it in Orchestrator and try running the process ,the package will be installed in this path—> C:\Users\[user_name]\.nuget\packages\[ProcessName]\[package_Version]\lib\net45\ .
Now when the job runs it will create the file here.


There is no issue with permission to write file and there is no option for ContinueOnError for append line activity.

perfect. thanks.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.