Text Exists, screen scrapping working only once in a loop

Hi Guys,

I am trying to automate a terminal which looks more or less like an Putty/powershell. This activity runs in a loop and the issue is, i am trying to find for a specific business exception using text exists, It works first iteration but from the second iteration , it is not able to detect it.

so i tried a different approach of scrapping the terminal screen and then checking , if that string contains that specific message . It is also working for the first iteration.

when the second iteration comes, it is not able to scrap it . It is returning null value.

key points :

  1. Text Exists , Screen Scrapping works only on first iteration and second iteration it fails.

  2. there is no selector issue, with Ui explorer i have checked it and the selector stays the same.

  3. i tried stopping the bot at the second iteration and scrapped it with a test sequence and it worked.

what could possibly be wrong here ?

I ran into a similar issue in a different context. Although I did not find a clear answer, it seemed like a caching issue to me (done by UiPath). Try to make sure the loop includes the “attach window” or whatever you’re using. And even do something else in the loop also e.g. find a different text, just to make sure you invalidate the cache. Hope this helps.

1 Like