Text Exists activity is not working with the characters like $,

Hello Everyone

@aksh1yadav @badita @ddpadil I am trying to search an amount field on a webpage. In the below link when I tried to find the text “39” with Text exists activity ,it is returning True. But with “$39”, it is returning False.

Can any one let me know alternative solution to find whether that particular amount is available in the page. In my use case, I have to search for the amount value like “$12,234.98”. So I will be having 3 extra characters which are not numbers or alphabets.

Note: Browser IE used for this use case

Thanks in advance

Interesting! Doesnt work with the dot too, like 39.99.
Trying to check on this

Try text exist with "\$12,234.98"

Tried that. Doesnt work too! :frowning_face:

Meanwhile if you are looking for a work around, you can use Element Exists activity, with a dynamic selector like this.

"<html title='Amazon.com: amazon web services' /><webctrl aaname='" + price + "*' parentid='result_*' tag='DIV' />"

where price would be “$12,234.98”.
This works!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.