"Text Exists"-Activity is not working in FireFox 60

Hi,
i’m using FireFox 60.0.2 (extension is installed).

All activities i’ve used so far are working fine, but i can’t get the “Text Exists”-activity working. I don’t think it is a problem with my page or my robot-script, because it also didn’t work on any other page i tried.

Here someone suggested to use IE. I tried it and it immediatly worked.

So, is this a known bug? Will it get fixed?

Can you share a screenshot or selector what you are using

I’ve attached a simple demo:
It opens google and checks if there is a button with the text “Search”.

It works as expected with IE, but not with FireFox 60.0.2

TextExistsDemo.xaml (7.7 KB)

It worked flawlessly on my machine, please indicate on screen and get a new selector, something like this may be

image

Same here, no matter what which I selector I indicate on. It doesn’t find the element.
Also using free community version on latest update with browser Add-On.
TextExistFirefox.xaml (6.9 KB)

@maurpalmenice

Try this

TextExistFirefox.xaml (8.1 KB)

If you want to detect a colorful text that will not work, you can also use Element Exists or Image exists rather.

Thanks,
Prankur

1 Like

Hey Thank you @PrankurJoshi!
The file worked and helps a lot!

Have a great Weekend!

1 Like