Terminal Session does not close

I am automating an application using IBM ehl api.
My problem is that the terminal session sometimes hangs during execution. It does not timeout or fail, it just stops, then after about 10 minutes it resumes like nothing has happened.
This occurs in about 20% of the transactions.
The debug log looks like this:

Terminal Session Executing
Do Executing
Set Field Username Executing
Set Field Username Closed
Set Field Password Executing
Set Field Password Closed
Send Control Key Executing
Send Control Key Closed
Do Closed

Then it stops for 10 minutes befor the terminal session is closed.

Has anyone else experienced this?

1 Like

yes I have the same issue, but not yet resolved

I ended up with using “kill process” on the terminal session process. Was not able to find another solution.

Hi @hLien ,
I am also facing same issue. Sometimes execution gets stuck at the end of terminal session activity for 10 mins. LogMessage activity which is added after terminal session activity scope gets executed after 10 minutes.

Have you found any other solution apart from kill process activity. Also are you able to use kill process activity inside the terminal session scope without any exception being thrown.

@loginerror can you please look into above issue and propose and solution to overcome.

I am afraid that I was not able to find any other solution, than to kill the process. I cant recall having problems with exceptions being thrown, could it i be possibility to set “continue on error” to “true”?

Hi @hLien, @Theepan, @loginerror,

Just an update…We are facing this issue while testing the workflow in developer machine (VM) in unattended mode by triggering it from Orchestrator.

However when we tested same workflow repeatedly in TEST environment (it is Windows Server configured using high density robot feature) , it worked perfectly fine without any issue.

Issue still persists on developer VMs. Unable to find the root cause.

Yes @san.nagane some others also encountering same problem.

UiPath Workflow getting Stuck for 10 minutes

Waiting for response from @loginerror @ovi

Hi @loginerror, @ovi,

Any suggestions on this issue.

In event viewer below exception gets logged however workflow does not fault. It continues executing terminal activities after 10 minutes.

Error details from Event Viewer:

"Connection lost: System.TimeoutException: This request operation sent to net.pipe://localhost/UiPath.Terminal.Host/HostService_10844 did not receive a reply within configured timeout(00:10:00).”


@cornel Can you please look into this issue


Can you please answer these
UiPath Workflow getting Stuck for 10 minutes - #9 by cornel

Terminal Connection should be initialized and existing connection string should be used throughout the project to avoid this issue.While connection establishment ,it is better not to have to have any terminal activities inside it.While re-using the connection,we can have all terminal activities to avoid issue in terminal closure/avoid UiPath stuck for 10mins.

I am using a creating a Session during the initialize phase of the UiPath Framework and reusing the same session for all the workflow/Sequence. But still i am getting this issue after calling the CloseApplication Sequence in which i am ending the IBM Session.
And when trying to open the IBM Session again it is not able to connect and there is a timeout error.

I am using the Kill Process but still i am having this issue.

Any resolution would really help

I had the same issue and couldn’t use terminal session. Tried to use kill but without any luck. Then I rebooted the machine and then i worked. I seems like that the uipath terminal got stuck because I could open the teminal emulater program but I could not use Terminal session from UiPath.