Temporary compiler error when changing generic variable type

datatypes
studio
error
variable

#1

Scenario: I create a generic variable and then change its type to a string. I get a compiler error.

Steps to reproduce: In the “Result” field of an “Input Dialog” activity, I create a variable “lastname” using the shortcut “ctrl+k”. Then in the Variables tab I change the variable type from “Generic” to “String”. Then I get a compiler error on the “Result” field of the activity. If I then clear the field, and retype the variable name, the error goes away.

Current Behavior: Error appears, and the variable needs to be retyped to make the error go away.

Expected Behavior: Variable type is changed without an error.

Studio Version: 2017.1.6435

Last stable behavior: n/a
Last stable version: n/a
OS Version: Windows 10 Pro

Screenshot:
UiPath_StringError

Workflow:
Error_GenericType.xaml (5.3 KB)


#2

Error_GenericType.xaml (5.3 KB)

Hi @PHorniak see the attached file the error is gone
after changing from generic to string if it shows error just delete the name from the place where it shows error and again retype the lastname variable the error will be gone.

regards


#3

Hi @PHorniak ,
Sometimes its happens with me also. All you have to do is
1.change generic value to string
2.then click on Result window(lastname)
3.then put (lastname.tostring)
4.click outside of result window(it still shows error)
5.now change result lastname.tosting to lastname

This worked for me hope it will also worked for you…:blush::+1::+1::+1:

Aditya


#4

Hi @rahatadi and @Samurai. Thanks for replicating my issue.
Those are good workarounds. I think this error should not happen in the first place, as it will confuse users. Is this the right forum to request changes to UiPath Studio?