Task Scheduler Logged Off


#1

I’ve been using task scheduler to run UiPath processes.
Running them under a locked screen works fine, but I can’t get it to run when the user is logged off.
“Run whether logged in or not” option is checked.
I am able to run a simple batch file using the same task scheduler settings while logged off.
I also tried creating a batch file that runs my UiPath process, and then scheduling that batch file, also didn’t work.

Does anyone have any advice?

Thanks,
Ian


#2

I guess your question isn’t necessarily a UiPath question, since it’s using Task Scheduler. I have a Task scheduled (unrelated to UiPath) and could never get it to trigger while the user has no session open ie logged off. Is there any information in the Event Viewer or in the Task logs inside Task Scheduler that says anything? I mean if it won’t even get kicked off (like it doesn’t show that it ran or tried to run) then you might need to consult your IT people or research online.

Again, I could not get a task to work when the user was logged off using Windows Server 2012, so I’m not sure what the problem is (wish I did)

However, if your job is running but it keeps failing like “Selector not found” or Timeout issues or “Logon session doesn’t exist”, then it’s a UiPath issue, and I would also recommend testing the job to work in the back screen prior to scheduling. One way to do this is with Launch Interactive and check LogonToConsole to True, and it will kick you off the server.

Regards.


#3

Hi Clayton,
Task logs in task scheduler show that the task started running, but it finishes running instantly.
There is no record in UiPath logs that shows the process even started.
In the event viewer however, everytime I tried to run a task logged off, there are three instances of the same error.

The error says:

{“message”:“Executor start process failed, reason System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))\r\n at UiPath.UiSystemClass.OpenInteractiveWindowsSession(String bstrUser, String bstrPassword, UiOpenSessionFlags nFlags, String bstrApplication, String bstrAppArguments, Int32 nDelayMs, Int32 userToken, UiGenericOptions options)\r\n at UiPath.Core.Setup.OpenInteractiveWindowsSession(String username, String password, OpenSessionFlags flags, String application, String arguments, Int32 userToken, Int32 preferredWidth, Int32 preferredHeight, Int32 preferredDepth)\r\n at UiPath.Service.Impl.Executor.StartProcessInSession(Guid executorInstanceId, String username, String password, SettingsDictionary execSettings, IntPtr userToken)\r\n at UiPath.Service.Impl.Executor.<>c__DisplayClass15_1.<b__0>d.MoveNext()”,“level”:“Error”,“logType”:“Default”,“timeStamp”:“2018-05-15T09:11:18.6830185-10:00”,“fingerprint”:“4b7b2850-94b0-4810-beb8-6ba7e3f87c1a”}

I read in another post that user credentials need to be added to Windows Credentials Manager, but I haven’t tried that yet. Since the error says access denied, adding the credentials may be the solution.


#4

I got it to work after adding the credentials in Windows Credentials Manager.

Needed to add a Generic Credential in the following format:

Internet of network address: UiPath:user=domain\username
User name: domain\username
Password: password