System.Activities 6.0.3 not found

Sure, I followed the advice of @Aeryn_Connerley.

Changed Project.Activities UiPath.Workflow.Runtime from 6.0.3 to

I then packed Project.Activities.Design to create a nuget package.

It installed without issue on Studio. Just for reference, I’m using Community 2022.10.3 to test this.


1 Like

@Hugo_Casqueiro I’m not seeing UiPath.Workflow.Runtime referenced anywhere? It looks like you used the Activity Creator VS Extension? V4.0 I’m assuming? Is there a reason you’ve heavily modified the async timeout structure provided by the activity creator? Also looks like you must’ve made the SubmitDocumentResponse required but changed your mind and updated that in the CacheMetadata section?
It might be worth starting from a clean slate using Activity Creator newest version (if not already) don’t modify any structure in the project other than the references to packages that aren’t supported. (e.g. the too new version of UiPath.Workflow.Runtime, not sure if you need to modify any others, only perform one modification each time and republish your packages in debug mode so that you get new version numbers, package your project into nuget simply by right clicking on the design project and publishing from there.)

Side note: just to keep things simple for a first attempt, maybe don’t use the timeout functionality and just try a simple activity with no timeout

Thanks @Aeryn_Connerley I’ve done a new project again from scratch, based on Activity Creator, and it seems fine. I think the last problems was raised after updating nuget references, as VS suggests. So, no references updates.

Dear All ,

I have migrated the project. But when I install the package into the UiPath Studio. It is give the bellow error.

Here is the package.

BalaReva.EncryptDecrypt.1.0.0.nupkg (16.6 KB)


Hi, I am getting the same error using .NET6, could you please say is it somehow solved now?

I have set “CopyLocalLockFileAssemblies” property to “true” in the csproj file and the issue has gone!

1 Like

Anyone resolve this problem yet ?

I honestly gave up for awhile on this as I had other priorities on my plate and UiPath has not been forthcoming with a clear response to the question proposed. I haven’t tried the update in the past written by Khachik Gejagezyan. Either way, the burden should fall upon UiPath to provide better, clearer documentation.

1 Like

Now I Resolved problem by way install some NuGet package in my computer first, and then create new template package, problem will be resolved.

Can I check,

You just need an example that works for Windows compatibility right?

I can probably knock that together pretty easily I think.