System.Activities 6.0.3 not found


I am trying to develop a custom activity using VS2022 and .net6.0. I have included UiPath.Workflow and UiPath.Workflow.Runtime in my project.

But when I try to include the nupkg in Uipath (2022.4.3) I am getting error that System.Activites 6.0.3 is not found. Kindly guide.

I am attaching reference screenshots below:

@balupad14 can you kindly guide. Thanks


Hello @atinder

Is there any other dependency packages in the uipath.workflow and uipath.workflow.runtime which is not the default package? Then try to install those and try adding this custom package.

All dependencies are install and even UiPath.Workflow.Runtime list System.Activites but still UiPath Studio gives error.


Hi @balupad14 , can you please guide on this. Thanks

I’m seeing the same thing.

A quick update on this - After a long discussion with UiPath Marketplace team, they have approved my custom activity code in .Net4.6 to be published on Marketplace.

I am assuming that the UiPath Dev team is currently working on this System.Activities for .net Core or higher stable version.


1 Like

Thank you for the feedback.
So did they say the UiPath package for .net 6 is not yet working, and they are working on it?


I have the same issue. Do you have any updates on this?

Many thanks!

@atinder is your issue fixed now? @DragosPadurariu who are you refering to when you say “do you have updates on this?”. All the best.

1 Like

Hi @Alex_Gherghe and @DragosPadurariu

The issue is not fixed and UiPath is working on it. Kindly refer to my last comment:

Marketplace evaluator will allow you to publish activities written in the previous verison of .net untill future stable release. (This is what my understanding is. Also my activity is approved, published and live and it is written in .net4.6 only)

Let me know in case of any conerns.


1 Like

Hi, i am getting the same error when using .NET Core 6. Has this issue not been fixed yet?

1 Like

Hi, i am getting exactly the same error when using .NET Core 6. Any updates on this subject?
I’ve also tried:

  1. include in my .net project the System.Activities dll and System.ComponentModel.Composition dll copied from the UiPath Studio folder (I’m using Community 2022.10.3). Result:
    I can update my nuget package in UiPath Studio, but then it doesn’t compile:

  2. include in my .net project the UiPath.Workflow.Runtime package (v6.0.3). Result:
    I cannot update my nuget package in UiPath Studio:
    “Cannot load assembly: …\docdigitizer.v1\\lib/net6.0-windows7.0/DocDigitizer.V1.dll : System.IO.FileNotFoundException: Could not load file or assembly ‘System.Activities, Version=, Culture=neutral, PublicKeyToken=null’. The system cannot find the file specified.
    File name: ‘System.Activities, Version=, Culture=neutral, PublicKeyToken=null’
    at System.Reflection.RuntimeAssembly.GetExportedTypes()
    at UiPath.Studio.Plugin.Workflow.Services.AssemblyContainerBase.AddAssemblyInternal(Assembly assembly, String path)
    at UiPath.Studio.Plugin.Workflow.Services.AssemblyContainerBase.<>c__DisplayClass15_0.b__0(Tuple`2 range) …”

  3. include in my .net project the UiPath.Workflow.Runtime package (v6.0.3) and also the System.Activities dll and System.ComponentModel.Composition dll copied from the UiPath Studio folder. Same result as 2)

  4. same as above but replacing the System.Activities dll of the UiPath Studio by System.Activities 6.0.3 dll. Result: UiPath Studio is broken.

My suggestion to fix this, is update UiPath Studio to work with System.Activities 6.0.3.

What’s your suggestions?


1 Like

@Hugo_Casqueiro Use version 6.0.0* of UiPath.Workflow.Runtime

1 Like

You are a king amongst men. I had it set at 6.0.3. Thanks bro.

@loginerror could you merge this or link this to How to - C# - Net 5.0 / Net 6.0 - Cross-Platform - Code Activity / Native Activity

Hi, @Aeryn_Connerley I’m following your hint but same results (missing System.Activities, Version= while updating package in UiPath).
I changed UiPath.Workflow.Runtime to version 6.0.0 in my .net projet: “”.
However I think that UiPath.Workflow.Runtime nuget is available v6.0.3 only.
I don’t know much about UiPath, should I also change something in UiPath Studio? Could you guide me on that please?

Hi @hgk.sarmiento could you please describe your steps to overcome this issue?

Thanks a lot

@Hugo_Casqueiro Whether or not you’re using the Visual Studio UiPath Activity Creator Extension or creating the UiPath Activity project from scratch the way you edit dependencies / packages in .NET 6 Visual Studio projects is typically going to be by editing the .csproj file. In your project in Visual Studio select your .csproj file in the Solution Explorer (you may need to double click it to have it show up in the edit pane). In the original post of this thread that would be the dummyFLow csproj file.

Once you are in edit mode you will want to find the section with PackageReference. Find the UiPath.Workflow.Runtime package reference and for the version you should be able to change it to: 6.0.0-20220909-01 or wildcard it to 6.0.0-*. Save your project and it should refresh the package dependencies respective to that new version.

Side note: The typical package feed only has versions 6.0.3 and 6.0.0-alpha-20220106-04. The package feed has version 6.0.0-20220909-01. So if you don’t have that package feed as one of your package sources in Visual Studio then I’d recommend adding it. I’d also recommend adding and (at least until UiPath responds to my forum post and tells us / guides us which feed is officially official and will have all necessary packages - currently it seems like some of the packages are in disparate locations)

@Aeryn_Connerley Thank you for your kindness detailing all that.
Ok, I updated my .net project as you mentioned and now I can reference it in UiPath Studio (no more errors related with System.Activities, Version= ). However when I start debugging it throws this error:
Unexpected error has occurred during the library compilation process:
Unable to create activity builder for Main.xaml. Reason was ‘No matching constructor found on type ‘System.Activities.Activity’. You can use the Arguments or FactoryMethod directives to construct this type. No default constructor found for type ‘System.Activities.Activity’. You can use the Arguments or FactoryMethod directives to construct this type.’.

I retried it also with a new blank process from scratch, and without my reference it runs. When I install my reference (I’m doing it through Manage Packages) it throw’s the error above, even without any of my custom activities been used in the mainflow.

Thank you very much

What does your actual csproj file look like? Attach if possible or copy paste as code to here. What does your class file for your activity look like? Attach if possible or copy paste to here.

Hi @Aeryn_Connerley I’ve uploaded in a zip file to UiPath-Connector/ at hcasqueiro-patch-1 · DocDigitizer/UiPath-Connector · GitHub

Thank you very much for your time