Syste.Aggregate Exception


I am getting error for Type into activity it throws Syste.AggregateException . Earlier it was working fine but now throwing errors when I added For each row today , can someone please help


Source: Type Into ‘Button’

Message: One or more errors occurred.

Exception Type: System.AggregateException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.AggregateException: One or more errors occurred. ----> System.ArgumentException: Value does not fall within the expected range.
at UiPath.UiBrowserClass.get_node()
at UiPath.Core.Browser.get_Element()
at UiPath.Core.Activities.Target.<>c__DisplayClass29_0.b__0()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()
— End of inner ExceptionDetail stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


what are you typing inside TypeInto activity.

This is really Browser dependent. Just as the behavior of the browser changes as a manual person clicks the same button repeatedly (due to cookies, trackers, etc) when the robot clicks the same button repeatedly the browser will behave differently.

A simple workaround I have found is to simply use the Refresh Page activity for that page to reload the browser.

I am trying to type into window search , Tried changing selectors still doesn’t work

I am typing " Change proxy settings" and then enter

Hi @XYZ_1991

See our troubleshooting guide here:

I think the first point applies here: