Support of Python Versions Higher than 3.6

@Pablito

Hello UiPath Developer Team,

in the current version 1.1.6863.33404 of UiPath.Python.Activities Pack from 2018/10/17 the highest supported version of Python is 3.6.

image

The current release of Python is 3.8. The support of release 3.6 ends at 2021/12/23 and security patches will be released only. Do you plan to support higher releases of Python in the near future?

Thanks and best regards
Stefan

Hi @StefanSchnell,
It’s a very good question. I’m very sorry that it takes so long but I will be back with the response :slight_smile: I’m in touch with our devs and waiting for information.

1 Like

@Pablito

Thank you very much Pawel. :smiley:

Hi @StefanSchnell,
I’m back with response :slight_smile:
So as it’s said HERE python package has been made an open-source project. Our devs used there 3rd party library which is currently supported up to 3.6 version. They stand that they are currently keeping up to date with version 3 of python. But to be honest we don’t know what it means. However you can monitor any current or future changes directly on package’s github project HERE as well as you can collaborate in this project :slight_smile:

Additionally you can check out this file if any newer library has been added:

1 Like

@Pablito

Thank you very much Pawel for this valuable information. :+1:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.