StudioX Won't Run Basic Automation Past "Checking for Validation Errors"


I’m completely new to this space and currently trying to run the intro automation modules alongside the StudioX tutorials. I follow each step exactly, but often when I go to “run” an automation, the screen takes a long while on the “Checking project for validation error” pop up box.

Once the box goes away, the errors list displays from the bottom of the screen, but there are zero errors found and the automation doesn’t run.

The only fix I have seemed to find is completely closing StudioX and starting the automation from scratch and even then, that doesn’t always work.

Could someone please help? A module that is only supposed to take 2 hours has increased to 4 just trying to get StudioX to run alongside the instructions.

I need to complete this pre work or I will be disenrolled.

Hello @derek.storm-larsen

Can you provide some screenshot at output panel when test run error?

Hi @NutchanonSwnl,

Thanks so much for your help. Attached is the screenshot.

I should also mention that I have attempted to uninstall and reinstall already.

Thanks for screenshot,

try use “analyze” function to check if there error,
or can you send your workflow file for me? i think there might be some error in flow. so i will
check and trying to find solution.

Thank you for the help. I have tried “analyze” as well as “validate” and the same thing occurs. I will attached both projects this has occurred on, but which file from the screenshot do you need me to send you specifically?

Send me both “GlobalhandlerX” and “Main”.
if “Project_Notebook” and “RuntimeExecutionError_Template” are material that needed for runing flow please also include it for me too into( all into zip files)

Thanks in advance

I have both files ready, but site is informing me I can’t upload because I am a new user…

Do you have another way I can send them to you?


Can you try renaming the project.json to any other name and then reopen the project please

Also can you show what activities you are using may be screenshots will do…

Also why do you have a chrome file in it?


Hi @Anil_G ,

The renaming might have worked (thank you) as it was able to run just now, but I won’t have time to fully test it again until tomorrow morning…

It appears to be working with the other file that I did not rename though too so unsure at this time.

Below are some of the activities. The others I have used are “type into”, “get text”, “select item”.

I don’t know why there’s a chrome file there…it was already there when I began working the project - could this be the issue?

One last thing I forgot to mention. Occassionally when I drag and drop the activities into the developer panel, they don’t add or respond. Clicking on the plus button does not work either. I have to close the application and start again to see if it works…

When I downloaded UiPath Studio, it didn’t give me the option to select the “Stable” version of the file like it shows in the tutorial video. It just downloaded the file automatically.

Could this be the issue?


  1. You can delete that chrome file and see …it looks just like a error teport created can open it and it must be contiani g some error details only…i guess even i fyou remove it would still create …so anything is fine then
  2. Can you change the system activities and ui automation packages to lower versions and check it might be that the ltest versions of packages are not stable and you might be seeing this…you can do this from manage packages option on the top

Hope this helps


Do you mean the section below that says “Version”?

For instance, the drop down creates a list and the next one says “23.4.1 preview” are you saying to move everyone of the packages down a version and test from there?

And if so, do the “preview” ones cause any concern? Should I choose versions that don’t list “preview” after the number?

Here’s the screenshot for my above post

Try degrade package version to 22.10.5 for both UIAutomation and System and test run this process

and also can you try create new project and add message box “Hello world” and test run to see if there error or not?

Degrading the packages seems to have fixed the activities not working (thank you), but my initial post about “checking for validation errors” is still occurring. It’s been stuck on the below screen for more than 2 minutes.

I notice that when the automation does run, it doesn’t show me the automation I’ve built. The screen freezes for a bit as if the program isn’t responding, flashes, and then reads “last run successful” at the top. The tutorial vids actually show how the automation executing step by step so perhaps the issue is here?

@NutchanonSwnl I’m sorry but I’m not sure what you mean by add message box “Hello world”…do you mean to name the project that?

Update to the above. Just created a whole new project from scratch to run again using the solutions suggested here. The above issues still occurred from time to time and I had to close the application completely and reopen to continue.

I was able to finally get to the end of the automation I was creating and it even produced the desired result, but the automation itself wouldn’t complete by itself. I ended up having to click “stop” after it stayed on “running” for approximately 5 minutes.

Again, it produced the automation I created, but it looks like the application is still experiencing errors that keep it from running seamlessly…

I have make some sample workflow for you

Main.xaml (30.5 KB)
project.json (1.6 KB)
After downloaded, Create new folder for this and place both to folder then double-click on Main.xaml
Note : This Process use “Chrome” for opening website

This flow will open rpa website and fill name surname and RoleinCompany
After that it will get text from rpa website to fill into excel files

as i tested, it worked properly without problem or need manual click from user(Me)

please test and tell me result if got error some screenshot on error would be help also

Hello @NutchanonSwnl ,

My apologies for taking so long to reply - work has taken most of my time this week. Thank you very much for taking the time to build this projects.

There were 2 outcomes, the first resulted in the screen shot you see below and stating the “run failed”. The second indicated the run completed successfully


Unfortunately, the 3rd run produced the same error where the application gets caught on “checking for project validation erorrs” and then produces 0 errors in the report.

Here’s the screen shot for the 3rd run I referenced above

This one is coming from network problem or UiPath Assistant might got disconnected from server

This one you run successfully without problem right?

and for third one can you look at output panel it might show some log error