Hope Your doing Good!
I have noticed some naming convention is wrong for queues activities for Get transaction item .I checked different queue activities names both activities and properties name are same.
Please find the screen shot for Get transaction item
Here is showing correct naming convention for other queue activities.
If i am wrong kindly ignore.