Studio got SOAP Request: There was an error in compiling the proxy code

Hi there,

I am getting an issue when I try to perform a local WSDL. It occurs inside the Studio “SOAP Resquest Wizard” and the package “UiPath.WebAPI.Activities”.

I tried to invoke the button in Studio Wizard to test it but I got an error message "“Exception has been thrown by the target of an invocation.”.

And when I try to perform my sequence, the SOAP request step got another error “SOAP Request: There was an error in compiling the proxy code”

Does anybody know how to deal with this kind of situation?

Thanks in advance!

Just a quick question , is it working in SOAP UI? Does the URL returns you the XML when runs in the browser?

Yes. It has worked in SOAPUI properly. Following below the screen, thanks for the message.

and it is running in the browser

Then it has to work @silrochagomes, Not sure about the issue :slight_smile:

Is it deployed in the local IIS server of your machine?

No, the wsdl is deployed in (IBM BPM Server) which is “https” protocol, I am not sure if it is relationed but I also tried to use “http” mocking the wsdl in SoapUI but I got the same situation.

I took some pictures that is showing my environment.

Below the SOAP Request wizard:

Perfoming the webservices using sequence:

The Studio log:

Many thanks

Additional info the Studio version is 2019.4.4.


Are you getting the same error for all the methods in the wsdl? Or for that particular method? This is slight confusing for me.

Yes, for all methods is getting the same message.

Hello, i have the same problem in Studio version 2019.10.0 with a local WSDL, which is working fine in SoapUI. Any help is welcome.

Can you try to browse the wsdl from your local? I mean saving xml into a file and passing it to the activity

Yep, that’s the way i did it. I have the wsdl xml file on disk and opened it in the soap acitivty. Clicking “Get” gives the error message “There was an error in compiling the proxy code”.

In the meanwhile i created a Library and added a “New Service” with the same WSDL. After pressing “Load” it shows me a bit more
but again there is an error message “Service operations are not found” and i cannot save the Service. As mentioned before it works in SoapUI.

Yeah ok. Can you also post what is the error you are getting when you use the server wsdl for the same in soap activity?

Hello, have you found a solution for that issue? I have the same trouble with SOAP request and Swagger.

Did you find the solution? I my case I changed the integration from SOAP to Rest. But I did not try it again.