Studio git clone/init: failed to get server certificate: The handle is in the wrong state for the requested operation


I get the below error when push/pull from a gitlab repository

Error: LibGit2Sharp.LibGit2SharpException: failed to get server certificate: The handle is in the wrong state for the requested operation

at LibGit2Sharp.Core.Ensure.HandleError(Int32 result)
at LibGit2Sharp.Core.Proxy.git_remote_push(RemoteHandle remote, IEnumerable1 refSpecs, GitPushOptions opts) at LibGit2Sharp.Network.Push(Remote remote, IEnumerable1 pushRefSpecs, PushOptions pushOptions)
at LibGit2Sharp.Network.Push(Remote remote, String pushRefSpec, PushOptions pushOptions)
at UiPath.Studio.Plugin.Git.Services.PushService.<>c__DisplayClass2_0.b__0()
at UiPath.Studio.Plugin.Git.Desktop.Services.UiAuthenticationSession.Execute[T](ExecuteArgs1 args) at UiPath.Studio.Plugin.Git.Services.PushService.Push(IRepository repository, RemoteModel remote, Boolean forcePush) at UiPath.Studio.Plugin.Git.Desktop.Services.PushUiService.PushInternal(IRepository repository, RemoteModel remote, Boolean forcePush) at UiPath.Studio.Plugin.Git.Desktop.Services.PushUiService.<>c__DisplayClass17_0.<PushAsync>b__3(IRepository r) at UiPath.Studio.Plugin.Git.Services.GitSession.ExecuteInternal[TResult](Func2 action, Func1 repoFactory) at UiPath.Studio.Plugin.Git.Services.GitSession.<>c__DisplayClass17_01.b__1()
at System.Threading.Tasks.Task1.InnerInvoke() at System.Threading.ExecutionContext.RunFromThreadPoolDispatchLoop(Thread threadPoolThread, ExecutionContext executionContext, ContextCallback callback, Object state) --- End of stack trace from previous location --- at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot, Thread threadPoolThread) --- End of stack trace from previous location --- at UiPath.Studio.Plugin.Git.Services.GitSession.SafeExecuteAsync[TResult](Func1 action)
at UiPath.Studio.Plugin.Git.Services.GitSession.ExecuteAsync[TResult](Func`2 action)
at UiPath.Studio.Plugin.Git.Desktop.Services.PushUiService.PushAsync(IGitSession session), HResult -2146233088

I was previously working with git fine on the machine (VM running windows server 2012 r2) and for an unknown reason it has started failing

When I check “manage remotes” the values are the same as before the problem began. My local repo was in documents, I also tried initialising a project from a file under c:/users/my_user/test but got the same result. I still have access to the gitlab project.



Hello @robots2022!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly