Studio: Configuring Activity Layout Throws Error Message

Hello,

in the latest version (22.12.0-beta.11471) of Studio (Community Edition) the task Activity Layout throws an error message (see below) in a library project (Windows-Legacy). Any ideas how to fix that?

22.12.0-beta.11471+Branch.release-v22.12.0.Sha.d2325c659238e9a5bce4ec0fa2d550b0024490cb

Provide value on 'System.Windows.StaticResourceExtension' threw an exception.

Error: RemoteException wrapping System.Windows.Markup.XamlParseException: Provide value on 'System.Windows.StaticResourceExtension' threw an exception.  ---> RemoteException wrapping System.Exception: Cannot find resource named 'AccessibleColorPicker'. Resource names are case sensitive. 
   at System.Windows.StaticResourceExtension.ProvideValueInternal(IServiceProvider serviceProvider, Boolean allowDeferredReference)
   at System.Windows.StaticResourceExtension.ProvideValue(IServiceProvider serviceProvider)
   at MS.Internal.Xaml.Runtime.ClrObjectRuntime.CallProvideValue(MarkupExtension me, IServiceProvider serviceProvider)
	--- End of inner exception stack trace ---
   at System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
   at System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
   at System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
   at System.Windows.Application.LoadComponent(Object component, Uri resourceLocator)
   at UiPath.Studio.Plugin.Workflow.WorkflowInfo.Views.WorkflowInfoWindow.InitializeComponent()
   at UiPath.Studio.Plugin.Workflow.WorkflowInfo.Views.WorkflowInfoWindow..ctor(), HResult -2146233088

Best, Emerald.

Hello @Emerald

Does that mean you are using a custom library and the error is happening in that library?

Thanks

Yes, I provided the link to the documentation in my post.

Hi all, I am facing the same issue. I just upgraded from 22.4.4 to 22.10.4 to utilize this new feature. I have a windows-legacy library (created by me) and want to customize the layout of activities. If I do a right click on a xaml in project window and choose Activity Layout, I get immediately the same error message. If I convert the library to Windows (not legacy) then it works, but that mode has no Exchange activities which is needed for us - so is not an option for us.
So in short: library created in 22.4.4 in Windows Legacy mode, opened in 22.10.4 and then selecting Activity Layout menu item on any xaml throws an error:
image

I am using Enterprise 22.10.3 and this bug doesn’t appear, but neither does the option for a colour picker in legacy projects. I do not think it is supported, sounds like a bug was introduced that added the colour picker when it should only be available for Windows compatibility.

Perhaps you can try 22.10.3 and see if that fixes it?
UiPath tries to keep their download links simple so the specific version is not listed in the Orchestrator, but you can build the url yourself and get it
https://download.uipath.com/versions/22.10.3/UiPathStudio.msi

This is enterprise edition, which I assume you are using based on your version number.

Hi Jon, thanks for the info, I’ll give a try once I obtain an admin pwd from our IT :slight_smile:

So, it works with 22.10.3, but a bit strange. I see only these settings:


Tooltip works, but I do not know what to put into “Value” field. Anyway it disapperas after saving it.
The documentation shows much more properties even for windows legacy:

So I do not know if this still a bug I do something wrong.
Thanks

I have exact same error with 22.10.5 Enterprise.

Error occurs only with Windows-Legacy. It is not showing up with Windows Library.

Solution (BIG workaround):

If you want tooltip and link to help webpage create empty library as Windows project. Then go to Activity layout (right click on xaml and choose option from submenu) and provide tooltip and and link:

now right click that xaml and choose Open in text Editor and copy that line:

In Windows-Legacy Library I created activity with one argument. I added property for argument:

Now open this xaml file from Windows-Legacy Library in Notepad++ (or just Notepad) and paste that value copied from the other file:

Publish package.

Now in new project when you use this activity tooltip and link would be working:

image

I found another error:

When you publish library without compiling activities:
image

It has errors inside projects, where you are using it:

image

Problem is not occurring when I publish compiled library.

2 Likes

Same issue here. Studio Enterprise 22.10.5, Windows legacy library and immediate error when rightclicking on XAML and selecting Activity layout.

Provide value on ‘System.Windows.StaticResourceExtension’ threw an exception. —> RemoteException wrapping System.Exception: Cannot find resource named ‘AccessibleColorPicker’.

Edit; issue still here after updating dependencies to UiPath.systen.activities.23.4.3 and UiPath.uiautomation.activities.23.4.7.