Studio Compiler and Validator can't find custom class in activity

I’m running into a strange issue with my custom activity set. I recently converted our activity set to use a generalized SDK for our company API instead of having each component having repeated logic in it. The SDK included in my component as a requirement exposes a few different model classes for the data the API returns. These custom classes are then used by the component as part of the output.

UiPath studio sees and lists these classes fine when defining new variables. However the designer then throws validation errors in the properties windows. Essentially saying that the class is not defined.

I’ve even gone so far as to add the namespace for the class to the imports tab on the workflow. But I’m a loss as to why part of studio can see and understand these classes and the validater/compiler can not.

1 Like

Hi @Tori_Holmes-Kirk

Welcome to our UiPath Forum! :slight_smile:

I hope @DeanMauro could help here a little :slight_smile:

What is the type of your activity’s output? Is it something like List<CustomClass>? If so, this is a known issue in Studio. It will import List, but not CustomClass. To navigate this, we usually opt for CustomClass[ ] instead.

2 Likes

Hi! Thanks for the suggestion. Yeah, the output was a list of the custom class, I just tried switching it to an array instead but that had no effect. Let me share a bit more info. Previous to this version, the custom class existed in the actual activity package codebase. I was also returning a list of the object and that was working fine. I recently extracted all the business logic out to an SDK package which is consumed by the activity package. In essence, it’s now just UiPath activity wrapper around the SDK methods. The activities that return built in system classes are all working fine. However, any of the activities that use a custom class from the SDK are not working due to the issue with Studio not being able to use the custom Class, even though it seems to know they are there.

The specific error I’m getting is: “Reference required to assembly ‘netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51’ containing the base class ‘System.object’. Add one to your project.” This shows up as a validation error for any variable that is defined with the custom class.

I’ve been googling and trying things for a couple of days now, but I am stuck. Best guess is this is some weirdness around using netstandard2.0 for the SDK and .NET 4.6.1 for the activity set.

@Tori_Holmes-Kirk Did you manage to resolve this? I’ve had the same thing happen to me since most of our apps and api use dotnet core and our class libraries are compiled as netstandard libraries. It would be great to be able to use the same class libraries in UiPath Studio instead of replicating them as net 461 libraries.

Unfortunately, I never found a solution to this issue. I haven’t been working on this particular project in a few months though. Let me know if you figure out a solution.

I ran into an issue that gave the exact same error message.

“Reference required to assembly ‘netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51’ containing the base class ‘System.object’

I had created a C# .NET Standard Class library, created a NuGet package from the library and successfully installed it in my UIPath project. I could see and assign the classes to variables and reference them in the code but they caused compile errors with the dreaded message above.

I resolved this by creating the same library as a C# .NET Framework 4.6.1 library and BINGO, the new package installed and the compile issues were resolved.

2 Likes

UiPath Studio doesn’t yet support .NET Standard. If a library requires it or has the netstandard library as a dependency, it will not work.

2 Likes

Are there any plans for supporting .NET Standard or preferably .NET 5.0? If yes, what does the timeline look like?

The .NET Framework is dead, .NET Standard is dying and .NET 5.0 and later is the future.

1 Like

Hi @kristianstad_johannes

Welcome to our UiPath Forum! :slight_smile:

Although I cannot disclose any specifics around the timeline, this is something that our team is looking into.