Studio 20918.7.0 selector not returning HTML tags after upgrade

Ever since upgrading to UiPath 2019.7.0 when “spying” an element (sorry for the Blue Prism terminology) in Firefox (version 68.1 – 64-bit) with extension installed (version 9.0.6822)

the selector returns the follow tags (wnd, crtl):

 <wnd app='firefox.exe' cls='MozillaWindowClass' title='Mozilla Firefox' />
 <ctrl name='Mozilla Firefox' role='application' />
 <ctrl idx='1' name='New Tab' role='document' />
 <ctrl name='@amazon Open context menu for @amazon' role='list item' />
 <ctrl name='@amazon' role='link' />
 <ctrl name='@amazon' role='editable text' />

or at times it returns uia tags:

 <wnd app='firefox.exe' cls='MozillaWindowClass' title='Mozilla Firefox' />
 <uia role='group' />
 <uia idx='1' role='list item' />
 <uia name='@amazon' role='edit' />

Instead of the html tags I was getting before the upgrade:

 <html app='firefox.exe' cls='MozillaWindowClass' title='Mozilla Firefox' />
 <webctrl idx='1' role='list item' />
 <webctrl name='@amazon' role='edit' />

It seems the element is “spyed” as a Win32 element and not an HTML element.

In addition, I am unable to select any element in Chrome. It returns the global html tag:

 <html app='chrome.exe' title='New Tab' />

even though I have the Chrome extension installed (version 9.0.6821)

Internet Explore works great; returning HTML tags.

Any ideas why I’m not getting HTML tags returned? (The site I need to run an automation against requires either Firefox or Chrome - IE and Edge are not an option)

Hello @Hibb

Try the below


Hi @Hibb

Welcome back! :slight_smile:

Could you try to downgrade/upgrade your UiPath.UiAutomation package via Package Manager? It is directly responsible for recognizing the elements on the screen.

I am wondering if different versions will give you different results.

Thanks for the tip. I really appreciate your help. This is very frustrating.

I am running the most current UiPath.UiAutomation version in the Package Manager.

Although my projects are loading very slow, and I am getting a significant number of warnings and errors when I load them.

Any additional insight you can provide is truly appreciated.


Thanks for the link Ajay. The documentation was very informative. I went through it comparing my setup to the documentation and here’s what I found:

I have the latest Firefox extension installed:



I noticed the ChromeNativeMessaging.exe process is not running when I open the Task Manager.

Further investigation in the Browser Console shows some errors:

In the registry I saw:



In the file C:\Users\Fritz\AppData\Local\UiPath\uipath-ff.json I saw:

Which is NOT the path in the documentation:

Based on the documentation and what I saw on my computer I believe there are some issues with my setup. Unfortunately, I’m not sure how to fix these inconsistencies. Any ideas on how/what I need to do?

Thanks again for all your help. It’s really appreciated.


Hi @Hibb

Let’s try like so:

  1. For the errors with packages, I would advise this:
    a) install latest .NET framework, this one.
    b) either clear cache folders:
    or give it a full fresh install as per this guide (I would advise this one)
    How to fix your Studio installation / Licensing issues

I would also advise you to uninstall all the extensions from the command line before reinstalling your Studio and then install them again from Studio.

Hi @loginerror,

Thanks for getting back to me. I have followed all of the items you suggested

I have the latest .net version (4.8) installed:


After uninstalling the Firefox extension, uninstalling UiPath using Apps and Features and manually deleting remaining artifacts



I reinstalled UiPath from

I am still getting the following warnings, but I’m not sure they are fatal, since they appear to be resolved by a later version:

However, I’m still receiving errors:


It appears UiPath is not recognizing .net 4.8

In Task Manager I don’t see ChromeNativeMessaging.exe running:

Examining Firefox’s Browser Controls I’m still getting errors. Which may give clues to why I’m having issues, but I don’t know what actions to take to resolve these errors:

When I open the Regedit:

I navigate to HKEY_CURRENT_USER\SOFTWARE\Mozilla\NativeMessagingHosts\com.uipath.chromenativemsg and find


When I open


I find:

This runs contrary to the documentation, which states:

Should uipath-ff.jason be in the folder

C:\Program Files (x86)\UiPath Studio\UiPath\BrowserExtension (as stated in documentation)

or in

C:\Users\Fritz\AppData\Local\UiPath (where it’s placed by the installtion process)

I’d like to also note I am running the latest version of Windows 10


Any additional advice you can provide to help resolve the problem of not getting HTML tags


would be very much appreciated.

Thanks again for all your help


Could you try a new project, with only the default packages installed?

Also, Studio Community Edition installs itself per user, thus in your %userprofile%\AppData\Local\UiPath folder. The documentation is written mostly based on the Enterprise version, and this is the cause of the discrepancy between the paths.

In your case, the Chrome messaging is pointed to the correct location.

I will research a bit what the MIME type error might mean for our extension. Just a thought, is your Firefox maybe blocking any scripts with an Adblock or something similar?
(I am not sure if it is relevant though)

I am a bit guessing here, but we’ll get it sorted out :slight_smile:

I tried a new project with only the default packages,


and received the same results


I also checked Firefox and there aren’t any scripts or Adblockers.

My theory is the extensions are functioning correctly. UiPath is “seeing” FireFox as if it were a win32 app, and not a browser. I’ve even gone so far as to rebuilt one of my computers from scratch and I’m still not getting HTML tags returned - only win32 tags.

Thanks for all your help - I know we’ll get this figured out.


This is a long shot, but I may have the same issue as @DjhRobot Master: UiPath is not using Uipath.Settings file

The following shows UiPath.settings file has not been accessed:

How would I determine if UiPath is accessing the UiPath.settings file, and if it’s not how do I configure UiPath to access the UiPath.settings file?

After several frustrating months of research through trial and error, I have discovered when “spying” Firefox (with the extension enabled) why the Selector stopped returning HTML code after it had been working for several years. Studio 2019.7.0 (and Studio 2019.8.0) are incompatible with my ASUS Maximus IX Hero graphics card! After I disabled the graphics card Selector once again returned instead of the being returned when the ASUS Maximus IX Hero graphics card was enabled.

It would be nice if UiPath looked into why there’s an incompatibility between Studio 2019.7.0 (and Studio 2019.8.0) and spying FireFox when my ASUS Maximus IX Hero graphics card is enabled. I think the answer lies in ChromeNativeMessaging.exe. Occasionally, for a short time, I could get ChromeNativeMessaging.exe to function, and get Selector to return , but with each reboot, it failed.