Studio 2020.10: Crashing

My studio is getting crashed whenever I try to run a process. I tried un-installing and re-installing the stable version. But still the issue persists.

I am running a very small process. The process reads 2 .xlsm files which has size 1mb+. The process just loops these two files and print out row values. Whenever I try to run the process studio crashes with Executor running in the background.

I am using the community version and is connected to the orchestrator via machine key. I have tried disconnecting the orchestrator, but still the same.

Update:

even if I download the 2020.10.1 version, it comes with the 2020.10.0 also.

@loginerror @Mircea.Grigore Please help. I tried re-installing multiple times and whenever I open studio and stars working on it it crashes.

Hi @amithvs

Do you have a clue what the path from the screenshot means? Is the file used in any way by your process?

It would help if you could send me the process via a PM, I’d have a look if I can reproduce this on my machine. Naturally, you don’t have to attach the Excel files, but it would be nice if you could send some files with dummy data that resembles your source Excel files.

Nope, the path in the screenshot doesn’t mean anything to the process.
Unfortunately I cannot share the files you asked. My colleague is also facing the same. This happens when we run in Debug mode. It first hangs and then crashes.

Also any idea why 2020.10.0 is also coming up when we download the lastest version, even the update chanel is “Stable” not “Beta”.

1 Like

@amithvs Thank you, that’s fine too. In this case:

  • could you click the Copy to Clipboard and paste here the full error message
  • could you collect the diagnostic data using the image and send me those via a PM
  • lastly, does this happen on all new projects, or just on the project from the screenshot?
  • knowing all activities used in the process would be helpful too
1 Like

Hi @amithvs, could you please also let us know if the process is under GIT source control? I noticed you have the status bar present, but the project is not marked as under source control.

  • if yes, have you used Studio or an external tool to add the project to GIT?
  • you mention the issue you are facing is only at Debug time, not Runtime, correct?
  • also, where do you download the latest version from that you mention comes with 20.10.0 included? is is the Resources Center from cloud.uipath.com?

Thank you :slight_smile:

  • The error above is not occurring anymore, but the crash does happen.
  • Currently it is happening only with current project I am working with.
  • Dependencies used

image

  • I will PM the Diagnostic info
1 Like
  • Yes, GIT is been used in this project. Pulled the files using Gitbash and opened it in studio

  • Yes, only during debug

  • Yes, downloaded from resource center inside cloud.uipath.com

image

1 Like

Thank you for the details, @amithvs. We will investigate the behavior.

Hi, any update on this? I am still facing this issue while debugging. Studio crashes first with uipath executor running in the background. I have to go to task manager to kill the process.

Hi @amithvs, unfortunately we have no resolution on this yet. We have a ticket logged internally for your case and we will get back as soon as we find an alternative. Thank you for your patience.

Okay, noted. Please keep me posted.

Even I am facing the same problem. I tried with simple message box. Then also it is not working.I have reinstalled it many times but still no luck. Not able to work for last 10 days and not even getting any solution. It is becoming frustrating.

Even I am facing with the same issue. Unable to work from the past 15days due to this issue.

Firstly, I got the invalid path error then I changed the location of path.Still it’s not working.

When I run the UIPath Studio,it crashes the studio and run executor in the background same as above.

Please let us know the fix to this problem as I am stuck up with so much of pending work.

Hi @Siddharth_Shankar and @ramamala, we apologize for the inconvenience, but for the moment we have no resolution for this. The issue is still tracked by us.
It would really help us if you could offer more details regarding the behavior - a Diagnostic Tool report would be awesome, as well as the steps you did that triggered the behavior.


Thank you for your patience!

Please find the requested log from Diagnostic tool as an attachment.DiagnosticToolExport-17-Nov-20.zip (1.8 MB)

I am still facing this issue, but not frequently. But tbh its frustrating. The invalid path error doesn’t make any sense.

@loginerror any update after going through the diagnostic report I provided?

DiagnosticToolExport-17-Nov-20.zip (1.2 MB)