Stuck on get asset activity - no error despite timeout

FIXED - see bottom edit

I am trying to grab an asset from orchestrator as I have done a million times before. The properties are set up fine, and the exact same activity with the same parameters works fine on another project on the same virtual machine.

It doesn’t fault, it just… hangs. This is what I see in debug mode;

asset%20error

I have tried the following fixes:

  • Restarting the robot service
  • Restarting studio
  • Testing the same activity in a different project - it works fine!
  • Removing and readding the output variable
  • Deleting and readding the entire get asset activity
  • Creating a new sequence to run - still doesn’t work because it’s in the same project
  • 3 second timeout on the activity (still hangs endlessly)

I can understand it if it was a timeout issue and the process faulted. But it doesn’t even fault, it just sits there. There are no issues with robot - orchestrator connectivity, because the exact same thing works on a different project on the same machine. I can see no differences between the 2 projects. I have triple checked the asset exists, and checked spelling etc.

Has anyone come across this before?

EDIT: I downgraded the UIPath.Systems.Activities dependency to 19.6.0 and it’s now working again. I can only assume it was down to a mismatch between our studio version and the package version it had tried to align it to.

Hi @KEntwistle,
Can you confirm that if you will update now the package to 19.8 version it will again stop working?
Are you able to show us the project/example in which this issue happens?

Hi @KEntwistle

The issue seems to be related to the robot process not running with the same version as Studio. It is easy to check, simply go to the Task Manager and check the path of the UiPath.Service.UserHost.exe file. If the path points to the previous app-19.7.0 folder, it will cause the issue.

The solution is to reinstall Studio.

1 Like

One thing @loginerror forgot:

  1. Open Task Manager
  2. Go to Details tab
  3. Click the right mouse button on any column name and chose “Select Columns”
    image
  4. Then select “Image path name” and confirm with OK button
    image
  5. You will see from which path service is working for Robot (it should be the folder with the same version than Studio. If it’s different, then as @loginerror said, you need to reinstall Studio.
    image
1 Like