Stuck in send smtp mail message activity

Hi…
I am facing an issue in send smtp mail message activity. In my process it got stuck in send mail message activity and it does not throw any error.
When i debug my workflow it gives an error that - “Timed out while waiting for mail service to connect”.

Few days ago it works perfectly now this issue occurs. If i restart my machine and then i run the workflow once again it runs perfectly and also send the mails. But after few hours same stuck appears in send smtp mail message activity.
how can i solve this issue?

1 Like

@arijit1213

After seeing the details of your issue, I believe there is some other app running in the background which is blocking the request

Can you check in EventViewer which is causing the issue or any log generated?

Hope this may help you

Thanks

1 Like

Did you solve the problem? Because I have the same problem :(. If so, write how?

1 Like

For anyone in the future that runs into this problem (although I was told it would be marked to be fixed in an upcoming version of the Mail activities), we needed to add ImapX as a dependency to the package. I had it already installed on my computer but the client’s PC did not. Once we added that everything was working!

Although my issue was with Get IMAP Messages i believe the Mail Activities is missing a few required dependencies, so try and dig into what those are and try adding them to your required packages directly.

1 Like

Hi Joseph,
Thank you very much for your contribution, could you please teach me how to add dependency to the package. How do I get dependency?

2 Likes