String comparation fails

Hello everyone,

I’ve a data input in a web browser application that isn’t very reliable. So, after choosing a option from a drop down I do a ‘Get Text’ activity to make sure the right option was selected.

If I match the getStringOuput = “Text” it fails… I works if it’s a getStringOutput.Contains = “PartialText”.
But fails with a expression with empty spaces getStringOutpu = “Some String” (even if replace the empty spaces using a expression).

But I need to use a variable since the optiion for this dropdown will be variable.

Things that I’ve tried:

  1. Compare the output expression with hardcoded string > Not equal
  2. Compare the output expression with a variable/argument > Not equal
  3. Use a .Contains expression with the variable/argument > Not equal
    3.2) Use a .contains expression with one word hardcoded string > MATCH
  4. Log both (output and argument) > text is the sam
  5. Write on a text file to check > text is the same

Can it be font related? Did this ever happened with someone?

Hi @iwishikn

check this


use replace fucntion as GetStringOutput.ToString.replace(" “,”")


Thank you, still not working.
And the goal would be to make work something like getOutputString.Equals(_StringOption)

Peraps the dropdown is “corrupted”.
Did you try the get attribute activitie (Attribute innertxt) ?

Not sure if this would help any… Might open another avenue for you.