Strange Issue: When I run Citrix RPA it runs from Orchestrator only when I'm watching it with RDP, but got error if do not watch

When I watch running RPA Job using RDP, it executed succesfully.
But when I run it without watching it, at one moment, OnImageAppear cause issue.
Please help!!!
@lukasziebold @PrankurJoshi @KarthikByggari @loginerror @badita @ClaytonM


this is a tricky topic. Check out my forum post collection on this topic below. I managed to make processes work on minimized RDP by adding a registry entry like this:

I wasn’t able to make image automation like Click Image or OnImageAppear work on closed RDP session though. Hope we can shed some more light on this :wink:

1 Like

It’s most likely a resolution problem. By default an unattended RDP connection will use like 800x600 or something. So, what you need to do is if you use Orchestrator, you can edit the Robots’ Runtime settings to use the same resolution you use when you develop (probably 1920x1080 32bit color). If you’re not using Orchestrator or as an alternative, you can use the Launch Workflow Interactive activity which allows you to Invoke your Main workflow with specific resolution settings.

You will also notice these kind of issues if you use a Take Screenshot step to figure out why your image is not being detected.

I hope this helps.


Try this solution

I’ve stumbled upon the same situation when delivering a project, all of my test cases in the UAT have been successful, the only catch was that I had the RDP window always on.

As soon as the process began running unattended and without having the RDP window open, Image Not Found error was thrown…I’ve managed to fix this issue in the two instances that generated the error by changing the Image Accuracy from 0.8 to 0.6.

To be frank, the image portions where very small and I have a feeling that they were being differently represented when not connected to the machine with RDP.