Stopping a job based on time of day

I have a process which is currently triggered by two previous jobs, the first job is scheduled to run on the 1st to the 7th of every month using a trigger in orchestrator, this job the triggers a load job to run on one robot which loads a queue, and the load job triggers the final work process to run across 3 robots.

I have a colleague’s job which needs running in the middle of my work process, at a specific time of day (11:30am) I need to now stop my Work process from running, only on one machine, to allow my colleagues process to run, and once my colleagues job is complete, resume my own work process.

Any ideas how to do this, I cannot do it using a trigger set to ‘stop after’ because the jobs I’m running are all based on working days, which is why they are triggered the way they are.

Is it possible to say IF the time is 11:10am stop my process on only one robot, which would allow the trigger on my colleagues process to execute and that process to run?? and if so how please?

1 Like

Hi @rebekah.batley ,

Most Probably I guess Resume After Delay would be of help here :

We would Require Persistence Package for this Activity to be used.

Let us know if this works.

Hey @rebekah.batley

For this scenario you can perform below steps,

In your process where you have Should Stop at the same point just include a logic to check the time and if the time is matching with other job’s trigger you should move to process else continue.

And then your colleague would start running and the above job which start should get auto triggered again since you have queue trigger enabled for that, which will continue running once your colleague job ran.

Hope that helps


Hi @supermanPunch

Thank you so much for your suggestion, this looks like the ideal answer to my solution.
I have put together a test process based around the parameters I need for the delay, this test process half runs in studio - the delay starts fine but the process does not resume without interaction by me, and when I loaded my test process to orchestrator and ran it that way I get the following error:

An extension of type ‘UiPath.Activities.Contracts.Persistence.IPersistenceBookmarks’ must be configured in order to run this workflow.

I have enabled supports persistence within the project settings, any ideas how to make this work?

@rebekah.batley ,

Have you also Installed the Persistence Package ?

I had, I just uninstalled it, then toggled Support Persistence off and back on in the settings, and then re-installed it and that seemed to do the trick, its working now. Thank you so much

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.