"Stop After" when Pending Job is Flawed

schedule

#1

Hello,

I think this is a design flaw, so I’m just pointing this out.

Orchestrator 2017.1
When scheduling a Job that Pends to the end of another Job that is running, the STOP AFTER property is counting the time during the Pending time.

I found this out when I had the Stop After set to 20 minutes but it needed to wait for another job to finish and it just stopped without running at exactly 20 minutes after its scheduled time; If it was scheduled at 6:00 when another job is running on that robot, it stopped at 6:20 without starting.

I believe the Stop After timing should begin when the Job actually starts or have an additional setting that can keep it from running if it’s passed a certain time along with the Stop After.

As a workaround, I will need to use a Robot that’s available at that time, set the Stop After time very long, or just turn off the setting.

Thanks.


#2

Hi Clayton

This is working as intended.
From the Orchestrator User Guide
"The amount of time specified in the Stop After section elapses according to the specifications, even if the job is queued. For example, if you schedule a job to run at 1 p.m. and set it to stop after 20 minutes, the job stops at 1:20 p.m. even if it had stayed in a queue until 1:15 p.m., and then started."


#3

Ok thanks ovi,

Any chance it can be looked at for a setting that starts timing after the Job has started also? It would be beneficial for jobs that get stuck in loops for some reason.

Thanks.


#4

For now there is no such setting, but i will raise this to the product team.

The idea behind the current behavior of the Stop After option is that you would know the exact time when a job will end and you can know exactly when to schedule another job on the same robot.

There are several ideas regarding Scheduling here on the forum: Scheduling Opinion
You could also post yours with more details :slight_smile: