Steps to Connect AWS machine instance to UiPath Or

Hello,
Can someone please list down steps to connect AWS machine Robot to Orchestrator(Which is on local machine). I am able to connect robot from Local machine to orchestrator but not with AWS Robot.
Notes:
I have Free Tier AWS instance on which I have installed UiPath
I have also installed UiPath on my lcoal machine and I have Uipath Orchestrator on Local machine.

https://orchestrator.uipath.com/docs/configuring-the-firewall

Make sure your local machine with Orchestrator can be reached from the EC2 instance. This may require changes to your router and/or firewall, if applicable (usually your FW would just drop any incoming request, especially on a client OS).

There’s an aweful lot going on with AWS or any other cloud infrastructure, not to mention a local one. It would be really helpful to know what you have tried so far (configuration, setup, and so on) and know what pieces have worked and what might not have, in order to allow others to provide feedback or possible solutions to your problem.

To extend @redlynx82 answer, the same also needs to be accounted for with AWS, I am going to assume that you have your VPC (Network ACLs), Subnets, and (Private or Public) Gateways configured.

Network Firewall
When you set up an EC2 instance for your Robot/Studio and Orchestrator, you still need to define your EC2 Security groups (AWS::EC2::SecurityGroup) for your interface and subnet traffic. On the Ingress, it is deny-all by default, so you have to explicitly indicate what you want to open up

In my case I have both robots and orchestrator on AWS, as such, I have a security group for each of my services, I then have a series of Ingress rules defined

  • Orchestrator

    • localnetwork:3389:tcp,
    • localnetwork:8…-1:icmp
    • localnetwork:443:tcp
    • robotSG:443:tcp
  • Robot

    • localnetwork:3389:tcp,
    • localnetwork:8…-1:icmp
    • localnetwork:443:tcp
    • robotSG:443:tcp
    • orchestratorSG:443:tcp

If you had an EC2 for SQL Server or RDS, you’d also want a security group for those services as well.

As you only have the robot on AWS (I’m assuming EC2 and not AWS Workstations) you wouldn’t need all of those, actually just the 443:tcp rules for Robot.

Host / OS Firewall
Don’t forget about the OS Firewall with your EC2 instances either by default on a Windows Server AMI, ICMP and 443 are blocked by default. While 443 already has a rule defined, it just needs to be enabled (unless of corse you want to define a new rule)

4 Likes

Great answer!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.