Start Job - Orchestrator Activity Not Working

Okay so I’m trying to use the ‘Start Job’ activity to start another process from a pre-job.

Our Folder structure and the package name is

The Activity
image

Studio is set to run in the same environment, so i’ve tested with and without folder defined in activity. and it gives the same error.
image

Error
image

When run from orchestratot i can see it adds an output variable that says ‘Test 2’, i’m guessing that is used for internal debug ?

I’ve tested both in the development and the production environment just to make sure it was the same, and it gives the same error

Also the help page for this activity seems really outdated and still have a major focus on classic, and some thing that is a general nuisance of any UIPath help page is the fact that there is never an example, the page literally says the same as the hover over info in studio. Having a working example from UIPath would be really helpful on their own activities.

it says i need to use packageName_Environment, except the last part doesn’t exist for modern folder. Start Job (uipath.com) I’ve also made sure to have to proper right on my Automation User role

Last thing. you need to add orchestrator to the option when creating topics, thx :slight_smile:

@loginerror Sorry to always poke you, but your always fast at getting answers and we are in a pinch to get this working. running the latest stable enterprise solution all activities fully updated to latest available (non-preview)

So much feedback I don’t know where to start :smiley:

Let’s get the smaller things out of the way first:

I’ve sent this feedback directly to our documentation team :slight_smile:

Technically, no. The list contains the activity package names, and the Orchestrator activities are part of the system package.
But I do know what you mean and we’ll see how to approach it and we’re happy to receive some feedback about that wizard :slight_smile:

Lastly, the errors.

First, I found two reasons for the BadRequest error. One is the wrong folder path, but there is also the fact that you need to put at least 1 in this property:
image

Then, for the folder path, based on this bit from the documentation:


I think when you are in root/production folder, the proper syntax would be

/production

where / means root already

In other words, to grab something from root in this scenario you would simply use / on its own.

It looks to be working with “/Production” and at last 1 in the robots for me :slight_smile:

Let me clearify things :slight_smile:

The folder named Root is just what I’ve called the main folder where we save our asset,s so we don’t need to update assets in two places and then we have Prod and Dev as a subfolder of that to share those assets. The “Root” folder is not the root of the folder structure, it’s just the name of the first folder in the root, we could name it ‘main’ or whatever, it’s just easy to remember :slight_smile:

To visualize this i’ve created another folder called “Root2”
image

Root and Root2 folder are in the root “/” to access those we have to go “/Root” and to access Dev or Prod we have to go “/Root/Production” or “/Root/Development”

If you look at my picture from my first post and we combine the two points you made, the folder path and numbers of robots, they are both set correct and they still give me this error

So according to the documentation this should work. but it doesn’t it’s returning, as the error states, “Bad Process Name”. According to the documentation it’s because Process name should be ‘packageName_enviroment’ and we only use ‘packageName’ in this case as there is no longer environment in modern folders, that was classic.

Indeed, the naming is not the most fortunate to stay on the same page here :sweat_smile:

However, just for the record, I still had your configuration available after we’ve been chatting about a similar situation, so my folders look the same. In fact, I’ve added the root2 just to see how it behaves:
image

So, with a process called like so in the Root2/Production folder:
image

I was able to start it from Root/Production folder like so:

So, for processes inside the subfolder, you can jump between the subfolders at the same level by simply doing:
/subfoldername, in our case /Production or /Development

And to grab something from the other folders you simply add the name of the top most folder before the /:
root2/production

As to the process name, could you drag and drop the process from the Resources tab and then select the Start Job? It should auto-fill the activity with the right process name:
image


image

Regarding the folder structure and what the different meaning is regarding

"/"
"./"
"../"

I get all those as it’s just like traversing any folder structure in CLI on windows or linux :slight_smile:

But even with your suggestion, dragging it out from resources and selecting “Start Job” and having the environment set to “Root/Production” in studio, when i run the process, it still return the ProcessName Error

image

image

image

image

Everything is updated
image

Is there an issue between Studio 21.4.3 , the activities and Orchestrator 2020.10.7 ?

Sorry for not so timely response.

This is strange, it makes me think whether some of the characters in your process name are at fault (and it being an obvious bug then).

could you try and test if that is the case in your end. i will try and test without period and underscore in the process name just to see if i can get it to run. we did find another solution, but we would still like this to work so we can revert our alternative solution to a proper one :slight_smile:

Hey @Rasmus_J ,

Can you try once by providing the Process name as input instead of the Package name.

i.e.
image

Since multiple processes can be created from same package, the name of the process must be specified.

It’s already been tried with the same result, I might not have been clear about that.
That was the first thing we did because that is what the help page for the activity states.

That is also why I’m tagging @loginerror in this so he can talk to the devs internally about what is going on here. What’s even more bonkers is the fact that when you drag out a deployed process from the resource pane, it chooses the package name instead of the process name when you select “start job”

EDIT:
I just tested another robot. without ‘ø’ in it and can conclude this is the issue. The robot runs just fine if the ‘Process Name’ only contains ASCII chars. I can also confirm that the activity is filled out incorrect if you drag it from resources. it’s missing the minimum requirements of robots and it’s using package name instead of process name. Activity is fully updated to latest version

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

Thanks for more context @Rasmus_J

I sent this issue to our issue tracker and our team will have a look.