Start Job on Moder Folder shows 'Conflict' Error

Good morning all,

•Context: I have 3 processes on my Modern Folder where one of the Processes just before finishing calls to execute one of the other 2 processes but is not been triggered. Same operation worked just fine before using ‘Classic Folder’.

•Scenario: ‘Start Job Activity’ is not been triggered showing the error on the image below:

image

•Not sure what it means about: ‘Conflict’

Thanks for your thoughts in advance!

PS, there is a similar issue here (Orch - Jobs Wont Start - Modern Folder) but has not response yet…

BY the way:

I also saw:
https://www.tutorialspoint.com/http/http_status_codes.htm
to learn from HTTP status code 409 but not sure what to change in order to fix it…

@loginerror @Pablito @ClaytonM

BE Safe!

1 Like

So your issue here is that you are executing a the start job activity, but it is returning a 409.It sounds to me like you are trying to start a job on an attended robot. Is the Job you are trying to start a job for associated with an unattended robot? If not then, it will not be possible to start a job.

1 Like

HI @MLillo,

Thanks for replying. I’m running the job from a Modern Folder, correct me if I’m wrong but I thought from Modern Folder you get Unattended Robots only?

Now I got confused because indeed on my Robots it indicates: Attended and Unattended as the img below:

Hi,

Great video, but there is no option for a ‘Local User’ under Classic Folder anymore!

image

Hello!

I thought from Modern Folder you get Unattended Robots only?

You can also have Attended Robots in Modern Folders: https://docs.uipath.com/orchestrator/docs/managing-robots-modern-folders#section-attended-setup

But, as @MLillo mentioned, you can only use the Start Job activity if you have an Unattended Robot.
From the screenshot you sent, you need to connect your Unattended Robot to make it work. To do so, you can follow the steps in the video you linked or in the documentation: https://docs.uipath.com/orchestrator/docs/managing-robots-modern-folders#section-unattended-setup

Also, note that if you want to start a Job using a Process that is in a different Folder, you need to specify the path to that Folder and the executing User must be assigned to it as well.

but there is no option for a ‘Local User’ under Classic Folder anymore!

And it is still possible to add local Users to on-premises versions of Orchestrator:
AddUsers
It’s not possible for Automation Cloud, because it manages Users in a different way: https://docs.uipath.com/automation-cloud/docs/managing-users

Hi @Mateus_Cruz

Thx for the info, it helps but I’m still trying to figure out some things.

I wanted to ask back about your comment below:

Context: As you can see I have 2 Folders. Where 3 processes listed inside a Modern Folder actually call ‘ModernFolder’

image

-I am trying to specify the path to that Modern Folder where my process reside now but no luck. See the img below.

•What would you write in the property field "Orchestrator Folder Path’ plz?

So far I’ve try:
• …/
• ./
•ModernFolder
•modernfolder
•…/…/
•/
•./

If any of those does not throw an error, I get this:

“OrchestratorJob[0] { }”

Be Safe!

Hi @Mateus_Cruz,

Thx for the comments, I’m trying to follow the steps but getting some obstacle:

image

At this moment I’m connected using ‘Service URL’. I had to use this option since ‘Processes List’ was not showing anything before on the UiPath assistant after the most recent updated last week so I started to use Modern Folder ever since. That was another issue and now that is solve not sure if I will touch it jeje.

The DOCs info is helpful of course but, still missing some update in re scenarios and it does not indocate specifically if using Classic or Modern Folders.

Be Safe!

You could just write the name of the Folder, like ModernFolder in your case. But if you have all Processes in the same Folder, there is no need to specify the FolderPath property. You only need to specify it if they were in different Folders.

Hi @Mateus_Cruz,

Thx for replying!

As you would imagine and I as indicated on the last reply I have tried your suggestion but, that is the issue, even if I enter the name is not taking the jobs from that folder so the question now is:

By default, which folder, ‘Default’ or ‘Modern Folder’, does the ‘Get Jobs’ activity’ gets the jobs from?

I ask because unfortunately, is not taking it from Modern Folder by default and although documentation is good does not state that specifically.

Regards,

Hold on, thank GOD! I think I’m getting to something…

If no Folder is specified, the activity uses the same Folder of the Process itself.

So just to confirm:

  • Are you still having the same “Conflict” error problem or is it something different?
  • Is your Unattended Robot showing connected (it was disconnected in a picture you sent before)?
  • Is the User associated with that Unattended Robot assigned to the Modern Folder with the appropriate Role (in this case, it needs a Role that can see and create Jobs)? Note that if the Modern Folder’s Role Assignment Model is Inherit from Tenant, then the Role must be configured at tenant level; if it is Custom Roles, then it is configured at Folder level.

Hi @Mateus_Cruz,

I’ll check the request and get back to you…

Hi @Mateus_Cruz,

No progress yet. I thought I was getting to something but the Documentation or videos I found does not cover some scenarios which are the ones I’m experiencing. Let me answer the inquiries as listed:

  • Are you still having the same “Conflict” error problem or is it something different?
    -Yes. Now I’m getting a ‘Bad Request’ error when one Job running call a another one when finished
    image

  • Is your Unattended Robot showing connected (it was disconnected in a picture you sent before)?
    -Good point and I looked into that. Let me see if I can explain myself or at least what I see in my Orchestrator: That robot is actually part of the same one above. Some how that ‘USER’ name is display when you click on the ‘Unattended Robot’ setting (step 3) as the img below shows so not really sure how to connect that besides as an Unattended Robot isn’t supposed to start working by itself!.

  • Is the User associated with that Unattended Robot assigned to the Modern Folder with the appropriate Role (in this case, it needs a Role that can see and create Jobs)? Note that if the Modern Folder’s Role Assignment Model is Inherit from Tenant , then the Role must be configured at tenant level; if it is Custom Roles , then it is configured at Folder level.
    -Yes. That User it is assigned to the ‘ModernFolder’ as the img below shows. Be aware I have added all possible ‘Roles’ under Role tab just to make sure.
    About the Role Assignment Model & Custom Roles I have added as much as possible just in case. See img below

Other Notes:
The thing is that no robot is been triggered to run the second job when first Project calls for it. I’ve been reading and searching of course but all is tide together. I mean one can’t do this beacuse it has to do with something else and so on such as:

•We can’t make a ‘New User’ because now you have to ‘Invite’
•We can’t really make a User because the options are for ‘Add’ Only, so it means that User/groups needs to exist Already. Although is welcome, the option/documentation you shared as an image on previous post is just not available in any ‘regular’ Orchestrator

Not sure what on-premises version you mean but this is my only options:
image

The ideas of a post is to make it direct to the point and this is loaded with too much info but just trying to reply to previous answers and other still not addressed.

Thanks for the support, hope to get your thoughts soon!

Regards,

Hello!
Thanks for the details.

So the first Process runs, but the second doesn’t get triggered, right?

Another things to confirm: Does the ProcessName property of the Start Job activity in the first Process match the new name of the Process in the Modern Folder?
In Classic Folders, the name of the Process would usually be something like MyPackage_MyEnvironment, but that probably changed to just MyPackage in the Modern Folder because there are no Environments, so it’s also necessary to update the first Package and publish it again.

I was reading the whole thread again and I realized this point here.
You cannot use unattended Robots with the Assistant’s Sign In feature.
To use Unattended Robots in Modern Folders, you need to specify a Machine Key of a Machine Template that is assigned to your Modern Folder.

For example:

Then on Orchestrator, you should see this on the Monitoring->Robot page:

Note that the Robot is connected to a Machine using a template called Template001. And you need to add this template to your Folder via the Management->Folder screen:

After that, just confirm that both Processes are correctly created in the Modern Folder (including the name of the Processed to be triggered, as I mentioned in the previous message) and it should work.

Hi @Mateus_Cruz,

Good info! Thank GOD! Robot is connected with Machine Key now and the steps you mentioned above are Ok! , see images below:

image

So let me check on the below comments and will keep you posted…

Regards,

1 Like

Hi All,

Thank GOD! is finally running,

It was a combination from many items and of course the Right Answer is among different Posts including this one at the end (Job failed when trying to run manually) since I started to have a ‘Password’ error after the ‘Bad request’ and ‘#1680’.

Basically in I was trying to Run a simple Job from ‘Project 1’ which at the end would call another Job named ‘Project 2’. The issue comes when different settings comes into place such:
•The Folder been used
•Type of Robot and if has password or not
•Type of Connection from UiPath Assistant (URL or Machine Key)
•What User and its name is configured in Orchestrator

In this Post in order to Resolve the Issue we can learn as follow:
-Get Jobs activity:
•Filter field: use the name of the Job you are using or targeting, if empty might list old job list
•Orchestratot Folder Path: Use the name of your Modern Folder, could be lower case

  • Start Job actiity:
    •NumberOfRobots field: use ‘1’ at least if using Unattended Robot, might throw error if empty
    •Orchestratot Folder Path: Use the name of your Modern Folder, could be lower case
    •Process Name field: make sure it matches the ‘Display Name’ if used the same name as the ‘Pacakage Name’

See imgs below:
Project #1
image

Project #2
image

image

I hope this Solution would help other persons coming to this scenario!

To anyone who helped, Thx for the support!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.