Ssh not showing after installation

I cannot see the packages installed in activity after installing the paakages.
Package name :
uiath version : 2018.4.3

Hi @ravi_gupta - as far as I can see this NuGet does not provide activities but the basis for developing your own code.

How can i connect but any option except the paclages…

You can take a look here - - these are custom activities developed by UiPath for connecting to SSH.

i have installed that only not working

Does it finally worked for you?

no it is not working…!

If using SSH.NET by Renci you would have to import the namespaces that are needed by Opening the Imports tab and searching for Renci.SshNet and selecting the required ones.

You would then use the Invoke Code Activity

I haven’t used either of these, but also looks like there is a UiPathTeam.SSHConnector.Activities package which depends on the SSH.NET package. This is the same one that @FrankSchikora mentions above.

This gives you two new activities SSH Connect Scope and SSH Run Command


Depending on your use case, are these packages sufficient for your needs? If not, you could also look at automating a Terminal Client like PuTTY.

If you provide more specific details of what you’ve tried and what is occuring / not occuring it would be easier for someone to assist.


If it is helpful to you @ravi_gupta and provides a solution to your problem, please do mark the above post as such to help others find workable solutions to similar problems.


1 Like

I have ended up with Using Putty…

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.