Some problems about type into

It‘s really hard to use type into well.In the picture, I type into Lot Number and Comment.
①If I don’t select properties-Options-ClickBeforeTyping ,it will both type into the default input box of Lot Number.
②If l select SendWindowMessages or StimulateType, input box seems be entered , but if I click OK to commit ,Error " Comment is empty " will happen. It has no actual effect.
③if I check in ClickBeforeTyping , it will run normally. But when I share my desktop with others,such as skype, all click operation in type into will be invalid.
I think it’s not a very complicated question,but I can’t overcome it will a stable method.

Hi @LeoGao

I faced the same scenario while I was automating one of the desktop applications. In my case, having simulate type typed the value in a totally different way and application didn’t recognize it properly. Additionally, similar to your case, I also had to use click before type because without it, it wasn’t working as I expect. At a time it types and sometimes it doesnt.

So in here, the best combination I found is to use type into without simulate type or window message but enabled click before type. This worked for me as it works for you now…

The other issue you mentioned that selectors being invalid while sharing the screen, not sure why that happens… I have done some screen sharing with users and I have seen others presenting it to me… but in all those occasions it worked fine… however, recently I saw a post in forum about a similar issue of getting selectors as invalid when sharing through Skype. Wonder whether its specific to the screen sharing application… I’ll have a look at it and see what I can find