[SOLVED] Object reference not set to an instance of an object - New Proyect

Hi,
I have a problem when I create a new Process project. When it is created, the main.xaml file appears in the structure from where I have made several executions previously.

But now I want to add a new process (Ctrl + N) inside the folder but when I try to execute anything (even just a Log Message) it shows the error of: Object reference not set to an instance of an object.

This stays even if I create a flowchart, form or any new window.

From the folder panel I set the new process as main but it keeps the same error.

It is understandable that for a particular project there is only one main and the others are objects to invoke. But in case I want to test in the other window to validate the flow, I have to disable or create new projects just because of this inconvenience.

Please, if you can help me with this. Thanks


Studio 2023.4.0-beta.12241 - 16/03/2023
Enterprise License
Per-user installation

License Provider: Orchestrator
Activation ID:

Microsoft Windows 10 Pro 64-bit
6.0.7

Structure-Project: https://i.imgur.com/3KCI0SL.png
Img-Error: https://i.imgur.com/YTLd2oU.png
Message-Error:
23.4.0-beta.12241+Branch.release-v23.4.0.Sha.be54cb29c47168fa58c4ddc437b353fa4a43364e

Object reference not set to an instance of an object.

Error: UiPath.WorkflowProcessor.Common.Exceptions.UiPathLocalizedException: Object reference not set to an instance of an object.
at UiPath.WorkflowProcessor.Common.Preprocessing.WorkflowDocumentPreprocessor.GetDependencyTree(LoggingScope scope, String xamlFilePath, IDictionary2 codeSourceFiles) at UiPath.Studio.ProjectCompiler.Services.ProjectCompilerService.<>c__DisplayClass9_0.<CalculateCompilationDependencies>b__1(String wf) at System.Linq.Enumerable.SelectEnumerableIterator2.MoveNext()
at System.Linq.Enumerable.SelectManySingleSelectorIterator2.MoveNext() at System.Linq.Enumerable.DistinctIterator1.MoveNext()
at System.Linq.Enumerable.WhereEnumerableIterator1.ToArray() at UiPath.Studio.Plugin.Workflow.Execution.Services.ExecutionCompilationService.CompileInternal(Boolean calculateWorkflowDependencies) at UiPath.Studio.Plugin.Workflow.Execution.Services.ExecutionCompilationService.Compile(String entryWorkflow) at UiPath.Studio.Plugin.Workflow.Execution.Services.ExecutionStartConfigurator.ConfigureAsync(Boolean firstExecutionInBatch, Boolean lastExecutionInBatch, IEnumerable1 batchedDocuments, String entryWorkflow)
at UiPath.Studio.Plugin.Workflow.Execution.Services.WorkflowExecutor.StartExecution(ExecutionConfig config)
at UiPath.Studio.Shell.Execution.Services.ExecutionManagerBaseService.TryStartExecution(ExecutionConfig executionConfig, Boolean validate)
at UiPath.Studio.Shell.Execution.Services.ExecutionManagerService.<>c__DisplayClass27_0.<g__StartExecutionAsync|1>d.MoveNext()
— End of stack trace from previous location —
at UiPath.Studio.Shell.Execution.Services.ExecutionManagerService.ProcessExecutionCommand(ExecutionCommand command, Object item, ExecutionParameters executionParameters)
at UiPath.Studio.Shell.Execution.ViewModels.DebugViewModel.ExecuteDebugAsync(IPersistableItem item, ExecutionParameters executionParameters)
at UiPath.Studio.Shell.ViewModels.DebugTabViewModel.ExecuteDebugFile()
at UiPath.Studio.App.Desktop.MVVM.Commands.TaskCommand`3.Execute(TExecuteParameter parameter, Boolean ignoreCanExecuteCheck)
at System.Threading.Tasks.Task.<>c.b__128_0(Object state)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler), HResult -2146233088

Hi @will.valverde

Welcome to forums

You are using a community edition and activated with a Enterprise License?
If you have a Enterprise License, then use the stable version which you got from your Organization

Hope this may help you

Thanks,
Srini

Hi,
Its a trial-version and i try reinstall UiPath but keep the same problem.
When create a new project and create a new sequence only for a Message Box or anything else its show the same error: Object Reference not set to an instance of an object

1- New Project

2- Message Box (Main):

3- New Sequence (Ctrl+N)
3.1- Main.xaml:

Hi Will, did you solve this problem, I have the same issue.

Cheers.

Hi, I have the same issue but with community edition.

Hi, everyone;
The issue was resolved. The problem was the community edition bc only allow 1 process for each project.
U can solved using any exercise of academy. Example:

Excel - Practice # 1

When u using any file enterprise u can add more workflow at the project.

Is not the correct solution but its a option.

Regards