Solved: Issues with Gmail IMAP Mail Messages

1.Enable IMAP in Gmail as shown in the article Here
2.Enable Less Security Apps in Gmail Account Here
3. Turn off Anti-Virus Shields (Error Msg: The remote certificate is invalid according to the validation procedure)
4.Update the Packages (As shown in the Image) to Latest version
image

Note: These workarounds helped me

5 Likes

Hi @Harvel

I agree with your solution however, disabling Anti-Virus is not viable at our end, can you please guide further on it? I already allowed port 993 on my firewall.

@mrkrunaldoshi, I don’t see much options for this but you can try to exempt the Uipath Robot from Anti-virus firewall and check.

Hi @Harvel,

UiPath is already exempted on my Anti Virus list but still, it was difficult in connecting with Gmail.

However, I resolved the issue, as I had mentioned in the below post:
https://forum.uipath.com/t/get-imap-mail-messages-with-anti-virus-enabled/147151/3