Solution for Click Text issues

Hi everyone,

I am trying to select specified entries from a list in an application based on a defined number.
As the application provides a selector for the whole table only and not for the single entries, I am using ‘Click Text’ activity to do so.
However ‘Click Text’ (still) confuses the numbers by picking the first occurence in the text.
i.e. Click Text “6” will click the “6” in “365” in below column example:
365
7
6

I have checked the existing solutions and I have seen that this has been taken into account for feature idea in 2019 but there seems to be no solution until today.
I tried building it by using find Text and then expand the clipping region and compare the values but however once again failed with the set clipping region.

Does anyone have an idea how to robustly solve this problem?

Hello @nicortak , If possible kindly share some screeshots of an application and selectors , it may useful to recognize the issue.

1 Like

Have you tried switching to the UIA or Accessibility frameworks? Sometimes they’re better able to identify elements.

1 Like

Hi @Gokul_Jayakumar,

unfortunately I can not share the real data / screenshots of the application but I can try to describe as much as possible.
We have an application that contains a table with different information, looking similar to this:

The table as a whole has a valid selector (ChildTable) that identifies the yellow highlighted element in the example:

In the use case I have to select all entries from month january (“01”) one by one as the application offers no filter options.

As for my current solution:
I have used ‘Get visible text’ and ‘Generate datatable’ activities to scrape the data from the table and create a datatable variable (page-by-page) which contains the same information as in the datatable in structured form:
image
(Note: Data extraction wizard etc. is not working so this is the more complicated but working way.)
I am then looping the table and for each row where date is the defined month I want to select the entry by using click text. Now as describved previously what happens is that when using click text it will click numbers within other numbers, i.e. for “3” there will be the red matches.

Hi @postwick

I just tried but unfortunately still ohnly the entire table is recognized as an element.

Try Click OCR Text and include the date before it in what it looks for to click. That would make “04.01.2022 3” unique whereas just “3” is not. I don’t know for sure it’ll work, but it’s worth a try.

not working either unfortunately… I have found an even older solution on the forum, apparently the problem is as old as UiPath itself :smiley:

However I am struggling to understand how to use ExpandClippingRegion Method with the variable. Can someone maybe help out? Woudl this be how it works?

Thanks in advance

1 Like